Package Details: pingg-git 0.0.12.1.g22a7f0b-1

Git Clone URL: https://aur.archlinux.org/pingg-git.git (read-only, click to copy)
Package Base: pingg-git
Description: Ping latency graphical CLI.
Upstream URL: http://gitlab.com/thann/pingg/
Keywords: blessed graph monitor ping
Licenses: Unlicense
Conflicts: pingg
Provides: pingg
Submitter: thann
Maintainer: thann
Last Packager: thann
Votes: 3
Popularity: 0.000004
First Submitted: 2019-04-05 10:06 (UTC)
Last Updated: 2021-07-17 21:34 (UTC)

Required by (0)

Sources (1)

Latest Comments

idanka commented on 2022-10-12 18:25 (UTC)

Perfect

thann commented on 2021-08-12 16:18 (UTC)

What did you run to get this error because semver shouldn't be a part of this project =/

I'm guessing that the version of npm you have is bugged somehow?

raulo.olapodrido commented on 2021-08-12 06:17 (UTC)

Hi! Does this work for anyone? I am getting the following error:

npm WARN old lockfile 
npm WARN old lockfile The package-lock.json file was created with an old version of npm,
npm WARN old lockfile so supplemental metadata must be fetched from the registry.
npm WARN old lockfile 
npm WARN old lockfile This is a one-time fix-up, please be patient...
npm WARN old lockfile 
npm ERR! semver.simplifyRange is not a function

The debug log ending with this:

615 verbose stack TypeError: semver.simplifyRange is not a function
615 verbose stack     at Advisory.[calculateRange] (/usr/lib/node_modules/npm/node_modules/@npmcli/metavuln-calculator/lib/advisory.js:191:16)
615 verbose stack     at Advisory.load (/usr/lib/node_modules/npm/node_modules/@npmcli/metavuln-calculator/lib/advisory.js:148:28)
615 verbose stack     at Calculator.[calculate] (/usr/lib/node_modules/npm/node_modules/@npmcli/metavuln-calculator/lib/index.js:59:14)
615 verbose stack     at async Promise.all (index 1)
615 verbose stack     at async Map.[init] (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/audit-report.js:180:7)
615 verbose stack     at async Map.run (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/audit-report.js:108:7)
616 verbose cwd /tmp/trizen-ehret/pingg-git/src/pingg-git
617 verbose Linux 5.12.1-arch1-1
618 verbose argv "/usr/bin/node" "/usr/bin/npm" "install" "--production"
619 verbose node v14.17.4
620 verbose npm  v7.20.5
621 error semver.simplifyRange is not a function

thann commented on 2021-07-17 21:38 (UTC) (edited on 2021-07-17 21:38 (UTC) by thann)

Sorry about that guys, the fuckers at NPM changed how everything works again =/

Let me know if you have anymore issues

thann commented on 2019-11-12 18:39 (UTC)

It could be, but then everyone will have to manually install it =/

silentnoodle commented on 2019-08-28 07:40 (UTC)

traceroute could be an optional dependency?