Package Details: pinta-git r2403.24d7473f-1

Git Clone URL: https://aur.archlinux.org/pinta-git.git (read-only, click to copy)
Package Base: pinta-git
Description: Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users
Upstream URL: https://pinta-project.com
Licenses: MIT
Conflicts: pinta
Provides: pinta
Submitter: kprkpr
Maintainer: kprkpr (JoseluCross)
Last Packager: kprkpr
Votes: 11
Popularity: 0.000217
First Submitted: 2016-06-22 10:46 (UTC)
Last Updated: 2022-01-04 18:38 (UTC)

Latest Comments

1 2 3 4 Next › Last »

ttoirrah commented on 2022-11-15 18:54 (UTC)

"You must have automake installed to compile Pinta."

humitos commented on 2022-11-15 12:07 (UTC) (edited on 2022-11-15 12:07 (UTC) by humitos)

It seems that Pinta requires dotnet 6.0 but 7.0 is installed:

▶ pinta 
You must install or update .NET to run this application.

App: /usr/lib/pinta/Pinta.dll
Architecture: x64
Framework: 'Microsoft.NETCore.App', version '6.0.0' (x64)
.NET location: /usr/share/dotnet/

The following frameworks were found:
  7.0.0 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]

Learn about framework resolution:
https://aka.ms/dotnet/app-launch-failed

To install missing framework, download:
https://aka.ms/dotnet-core-applaunch?framework=Microsoft.NETCore.App&framework_version=6.0.0&arch=x64&rid=arch-x64

FabioLolix commented on 2022-01-10 21:36 (UTC)

Can confirm the change of dependencies, made a chroot build and removed all mono/dotnet stuff install, please adjust depends and makedpends like this:

  • depends=(gtk3 dotnet-runtime)

  • makedepends=(git intltool dotnet-sdk)

Same as pinta in official repo + git

@hamedsbt what is your problem with mono & dotnet?

hamedsbt commented on 2022-01-08 05:49 (UTC)

mono & dotnet! are you kidding me?!

cameronwhite commented on 2022-01-07 03:46 (UTC)

(upstream maintainer here) With Pinta 2.0 I think a few of the dependencies shouldn't be necessary anymore: mono, mono-addins, yelp-tools, and gtk-sharp-3 (this looks like the outdated one, Pinta uses https://github.com/GtkSharp/GtkSharp via nuget)

kprkpr commented on 2022-01-04 18:38 (UTC)

Sorry for taking to long in updating it, now it's updating following the jsteinaker PKGBUILD @jsteinaker, if you want, I can add you as maintainer Thanks!

jsteinaker commented on 2021-12-14 02:17 (UTC)

Since Pinta's master branch now uses GTK3 and .NET 6, this is out-of-date. I've updated pinta-gtk3-git to build from master, but as soon as @kprkpr updates this the other package shouldn't be needed anymore

cameronwhite commented on 2021-10-25 16:02 (UTC)

Just a heads up that the GTK3 branch of Pinta was recently merged into the master branch, and the 'gtk2' branch now tracks the GTK2 version of Pinta.

jsteinaker commented on 2021-05-05 05:56 (UTC)

Hi, I just made a PKGBUILD for the GTK3 git branch, you can find it as pinta-gtk3. As it's my first package, feel free to point any mistakes you find. I haven't tested it a lot but at a first glance it works way better under Wayland than the GTK2 version (I'm having some problems with XWayland and -apparently- the Nouveau driver, not a single X app works as it should), and besides it's nice to run Pinta in Wayland native mode anyway.

kprkpr commented on 2021-04-04 17:46 (UTC)

Hi @atharraiz This is the -git version of the program, for problems with the software itself, if it's not at building stage, you can use the community one, or submit a bug at developers git (https://github.com/PintaProject/Pinta.git) Thanks