Package Details: pioneer 20220203-1

Git Clone URL: https://aur.archlinux.org/pioneer.git (read-only, click to copy)
Package Base: pioneer
Description: A game of lonely space adventure
Upstream URL: https://github.com/pioneerspacesim/pioneer
Keywords: game sim space
Licenses: GPL3
Conflicts: pioneer-bin, pioneer-git
Provides: pioneer
Submitter: yitzi
Maintainer: buzo
Last Packager: buzo
Votes: 24
Popularity: 0.000079
First Submitted: 2015-12-26 15:01 (UTC)
Last Updated: 2022-02-05 14:07 (UTC)

Latest Comments

buzo commented on 2021-03-20 23:11 (UTC)

Fixed – thanks Jeinzi for the hint. I hope it works now.

The docs for the Lua API should be included again, too.

Jeinzi commented on 2021-03-19 22:08 (UTC)

I also get the same error regarding the ground_station model and there already is a solved issue on Github.

Please adapt the PGKBUILD; time make all build-data works for me.

theogen commented on 2021-02-04 22:34 (UTC)

I have the same error as @vcalv, can't load the ground_station model. The pioneer-bin package, on the other hand, works without problems.

rwd2 commented on 2020-08-30 11:04 (UTC)

makepkg fails with:

==> Making package: pioneer 20200203-1 (Sun 30 Aug 2020 01:03:52 PM CEST) ==> Checking runtime dependencies... ==> Missing dependencies: -> assimp -> lua52 -> sdl2_image ==> Checking buildtime dependencies... ==> Missing dependencies: -> naturaldocs ==> ERROR: Could not resolve all dependencies.

vcalv commented on 2020-06-20 02:48 (UTC)

Error while trying to run:

couldn't initialize station type 'stations/ground_station.json' because the corresponding model ('ground_station') could not be found.

error: Error while loading Space Station data (check stdout/output.txt).

Un1Gfn commented on 2019-02-17 01:50 (UTC) (edited on 2019-02-17 01:56 (UTC) by Un1Gfn)

Dear @jcb2016

In Archlinux, /tmp defaults to tmpfs, which resides in RAM.

I don't think you have that much RAM to hold source code and build output of such a huge game.

Please do it in somewhere else instead of /tmp.

Succeed?

jcb2016 commented on 2019-02-17 01:36 (UTC) (edited on 2019-02-17 01:37 (UTC) by jcb2016)

I did a 1. cd /tmp 2. git clone 3. cd pioneer 4. makepkg -si

everything seemed fine until the end i kept getting these errors then it failed

pioneer-20190203/win32/vs2017/ui/ui.vcxproj: Write failed pioneer-20190203/win32/vs2017/ui/ui.vcxproj.filters: Write failed bsdtar: Error exit delayed from previous errors. ==> ERROR: Failed to extract pioneer-20190203.tar.gz

Un1Gfn commented on 2019-02-15 02:01 (UTC) (edited on 2019-02-15 09:48 (UTC) by Un1Gfn)

Update to version 20190203.

Please comment if you encounter any failures when building or playing.

khau commented on 2018-02-05 17:02 (UTC)

Requires autoconf and automake. I'm not sure what the norm is, based off of @boenki 's message, but it might be worth listing. If people have it from base-devel, it won't hurt. If they don't have it, it'll notify them. But again, I'm not sure what the norm is for listing those as dependencies.

joaojotta commented on 2017-09-30 19:39 (UTC)

Can't run the me: ver on: Linux System Name: Linux Host Name: i6400 Release(Kernel) Version: 4.13.3-1-ARCH Kernel Build Timestamp: #1 SMP PREEMPT Thu Sep 21 20:33:16 CEST 2017 Machine Arch: x86_64 Domain Name: (none) SDL Version 2.0.6 Initialized OpenGL 3.1, with extensions, renderer invalid axis binding '' in config file for BindAxisPitch invalid axis binding '' in config file for BindAxisRoll invalid axis binding '' in config file for BindAxisYaw started 3 worker threads ShipType::Init() Lua::Init() Fonts: font orbiteer: - DejaVuSans.ttf 1.200000 - wqy-microhei.ttc 1.000000 - Orbiteer-Bold.ttf 1.000000 font pionillium: - DejaVuSans.ttf 0.928571 - wqy-microhei.ttc 1.000000 - PionilliumText22L-Medium.ttf 1.000000 Segmentation fault Any tips?

joaojotta commented on 2017-09-30 19:39 (UTC)

Can't run the me: ver on: Linux System Name: Linux Host Name: i6400 Release(Kernel) Version: 4.13.3-1-ARCH Kernel Build Timestamp: #1 SMP PREEMPT Thu Sep 21 20:33:16 CEST 2017 Machine Arch: x86_64 Domain Name: (none) SDL Version 2.0.6 Initialized OpenGL 3.1, with extensions, renderer invalid axis binding '' in config file for BindAxisPitch invalid axis binding '' in config file for BindAxisRoll invalid axis binding '' in config file for BindAxisYaw started 3 worker threads ShipType::Init() Lua::Init() Fonts: font orbiteer: - DejaVuSans.ttf 1.200000 - wqy-microhei.ttc 1.000000 - Orbiteer-Bold.ttf 1.000000 font pionillium: - DejaVuSans.ttf 0.928571 - wqy-microhei.ttc 1.000000 - PionilliumText22L-Medium.ttf 1.000000 Segmentation fault Any tips?

kamelie1706 commented on 2017-03-28 16:48 (UTC)

I get *** Could not find naturaldocs ***

pirogronian commented on 2016-12-02 16:47 (UTC)

Works now. Thanks!

yitzi commented on 2016-12-02 14:41 (UTC)

Try now @pirogrionion

pirogronian commented on 2016-12-02 14:10 (UTC)

I got checksum error for file pioneer-20161129.tar.gz. Checked twice, inside clear folder.

yitzi commented on 2016-07-29 11:23 (UTC)

Fixed hash

pezz commented on 2016-07-29 04:31 (UTC)

Hash for pioneer-20160724.tar.gz is no good. :(

yitzi commented on 2016-05-07 12:52 (UTC)

Thanks boenki. Updated makedeps and source.

boenki commented on 2016-05-04 23:21 (UTC)

and the following makedeps are in base-devel, so you may remove them: "automake, gcc, pkg-config" see here: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites and git is also useless here, I think.

boenki commented on 2016-05-04 23:12 (UTC)

proposal for the source line: source=("$pkgname-$pkgver.tar.gz::http://github.com/pioneerspacesim/pioneer/archive/$pkgver.zip" 'pioneer.desktop') see here https://wiki.archlinux.org/index.php/PKGBUILD#source and do we still need the install file?

yitzi commented on 2016-02-19 12:19 (UTC)

Good catch zilbuz. Fixed.

zilbuz commented on 2016-02-19 12:11 (UTC)

It seems that the letter 'r' of 'pioneer' is missing in the 'export PIONEER_DATA_DIR' of the package command, line 29 of the PKGBUILD. Is it intentional?

pezz commented on 2016-01-19 13:24 (UTC)

Just built perfectly here after the update, thanks mate.

yitzi commented on 2016-01-19 11:17 (UTC)

Thanks pezz. Updated hash.

pezz commented on 2016-01-19 05:59 (UTC)

Hash for 20160116.zip is wrong.