Package Details: pioneer 20171001-1

Git Clone URL: https://aur.archlinux.org/pioneer.git (read-only)
Package Base: pioneer
Description: A game of lonely space adventure
Upstream URL: https://github.com/pioneerspacesim/pioneer
Keywords: game sim space
Licenses: GPL
Conflicts: pioneer-bin, pioneer-git
Provides: pioneer
Submitter: yitzi
Maintainer: yitzi
Last Packager: yitzi
Votes: 16
Popularity: 0.320804
First Submitted: 2015-12-26 15:01
Last Updated: 2017-10-01 15:25

Latest Comments

joaojotta commented on 2017-09-30 19:39

Can't run the me:

ver on: Linux

System Name: Linux
Host Name: i6400
Release(Kernel) Version: 4.13.3-1-ARCH
Kernel Build Timestamp: #1 SMP PREEMPT Thu Sep 21 20:33:16 CEST 2017
Machine Arch: x86_64
Domain Name: (none)

SDL Version 2.0.6
Initialized OpenGL 3.1, with extensions, renderer
invalid axis binding '' in config file for BindAxisPitch
invalid axis binding '' in config file for BindAxisRoll
invalid axis binding '' in config file for BindAxisYaw
started 3 worker threads
ShipType::Init()
Lua::Init()
Fonts:
font orbiteer:
- DejaVuSans.ttf 1.200000
- wqy-microhei.ttc 1.000000
- Orbiteer-Bold.ttf 1.000000
font pionillium:
- DejaVuSans.ttf 0.928571
- wqy-microhei.ttc 1.000000
- PionilliumText22L-Medium.ttf 1.000000
Segmentation fault



Any tips?

joaojotta commented on 2017-09-30 19:39

Can't run the me:

ver on: Linux

System Name: Linux
Host Name: i6400
Release(Kernel) Version: 4.13.3-1-ARCH
Kernel Build Timestamp: #1 SMP PREEMPT Thu Sep 21 20:33:16 CEST 2017
Machine Arch: x86_64
Domain Name: (none)

SDL Version 2.0.6
Initialized OpenGL 3.1, with extensions, renderer
invalid axis binding '' in config file for BindAxisPitch
invalid axis binding '' in config file for BindAxisRoll
invalid axis binding '' in config file for BindAxisYaw
started 3 worker threads
ShipType::Init()
Lua::Init()
Fonts:
font orbiteer:
- DejaVuSans.ttf 1.200000
- wqy-microhei.ttc 1.000000
- Orbiteer-Bold.ttf 1.000000
font pionillium:
- DejaVuSans.ttf 0.928571
- wqy-microhei.ttc 1.000000
- PionilliumText22L-Medium.ttf 1.000000
Segmentation fault



Any tips?

kamelie1706 commented on 2017-03-28 16:48

I get
***
Could not find naturaldocs
***

pirogronian commented on 2016-12-02 16:47

Works now. Thanks!

yitzi commented on 2016-12-02 14:41

Try now @pirogrionion

pirogronian commented on 2016-12-02 14:10

I got checksum error for file pioneer-20161129.tar.gz. Checked twice, inside clear folder.

yitzi commented on 2016-07-29 11:23

Fixed hash

pezz commented on 2016-07-29 04:31

Hash for pioneer-20160724.tar.gz is no good. :(

yitzi commented on 2016-05-07 12:52

Thanks boenki. Updated makedeps and source.

boenki commented on 2016-05-04 23:21

and the following makedeps are in base-devel, so you may remove them: "automake, gcc, pkg-config"
see here: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

and git is also useless here, I think.

boenki commented on 2016-05-04 23:12

proposal for the source line:
source=("$pkgname-$pkgver.tar.gz::http://github.com/pioneerspacesim/pioneer/archive/$pkgver.zip" 'pioneer.desktop')
see here https://wiki.archlinux.org/index.php/PKGBUILD#source

and do we still need the install file?

yitzi commented on 2016-02-19 12:19

Good catch zilbuz. Fixed.

zilbuz commented on 2016-02-19 12:11

It seems that the letter 'r' of 'pioneer' is missing in the 'export PIONEER_DATA_DIR' of the package command, line 29 of the PKGBUILD. Is it intentional?

pezz commented on 2016-01-19 13:24

Just built perfectly here after the update, thanks mate.

yitzi commented on 2016-01-19 11:17

Thanks pezz. Updated hash.

pezz commented on 2016-01-19 05:59

Hash for 20160116.zip is wrong.