Package Details: pitivi-git 0.98.7539.c7e8c309-1

Git Clone URL: https://aur.archlinux.org/pitivi-git.git (read-only)
Package Base: pitivi-git
Description: Pitivi allows users to easily edit audio/video projects based on the GStreamer framework (Git version)
Upstream URL: http://www.pitivi.org/
Licenses: LGPL
Conflicts: pitivi
Provides: pitivi
Submitter: None
Maintainer: lubosz
Last Packager: lubosz
Votes: 17
Popularity: 0.000070
First Submitted: 2009-05-16 18:16
Last Updated: 2017-06-21 05:02

Latest Comments

linkmauve commented on 2017-08-27 22:08

Hi, the update-* scripts you are calling in the install file aren’t needed since pacman 5.0, you can safely remove the install script altogether. :)

kozaki commented on 2017-06-19 20:22

Dependency issue:

$ pitivi
ERROR - The following hard dependencies are unmet:
==================================================
- gstgtk not found on the system
Missing soft dependency:
- pycanberra not found on the system
-> enables sound notifications when rendering is complete

Installing 'python-pycanberra-git' did not change the message.
Thank you for maintaining this package on Arch!

haawda commented on 2017-05-23 22:46

The PKGBUILD has some issues for me, e.g. gst-valitae seems to bee needed, and the pkgver version did not generate a sensible number for me, thus:

http://dpaste.com/1A5AW6G

ooo commented on 2016-07-22 16:51

pitivi switched to meson build system, and I updated the PKGBUILD for that:
https://www.dropbox.com/s/k040uts3a6ym0lf/PKGBUILD?dl=0

I also removed the now redundant .install file.

lubosz commented on 2016-07-03 09:32

@Fraterius: Sorry, you need GtkSink from gst-plugins-bad now. Added it as a dependency.

Fraterius commented on 2015-09-23 14:16

I just installed it. With manually installing python-pycanberra-git and python-matplotlib all errors are gone except:

Could not create video output sink. Make sure you have a gtksink avalaible.

Tanks for any help on getting it to work, I'd like to try it out. I'm not ueing it in GNOME but with simple awesome WM, maybe that's the problem from what I've read it's very integrated into GNOME.

Francois_B commented on 2015-07-17 01:19

Please, add python-cairo

Francois_B commented on 2015-01-03 23:57

Please, add python-pycanberra-git in deps.

BinaryMn commented on 2013-12-15 18:56

There is currently a dash in the revision, which is throwing a fatal error. The pkgver() function will need to be updated to strip any dashes.

Additionally, the Python include files are now being looked for in /usr/include instead of /usr/include/python`$version`. I've had to symlink Python.h and dependencies into /usr/include for this to build.

carstene1ns commented on 2013-10-09 15:24

Here are some fixes for this PKGBUILD:
- change case to "Pitivi" in pkgver().
- add yelp-tools to makedepends.
- export PYTHON=python2 before building.

See also pitivi package in communitiy repo for reference:
https://projects.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/pitivi

All comments