Package Details: pius 2.2.2-1

Git Clone URL: https://aur.archlinux.org/pius.git (read-only)
Package Base: pius
Description: PGP Individual UID Signer (PIUS)
Upstream URL: http://www.phildev.net/pius/
Licenses: GPL2
Submitter: encbladexp
Maintainer: zorun
Last Packager: zorun
Votes: 13
Popularity: 0.000164
First Submitted: 2010-10-18 20:31
Last Updated: 2016-01-17 10:58

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

zorun commented on 2016-01-17 11:02

2.2.2 has been released upstream! It should fix the signing issue.

zorun commented on 2015-12-07 14:06

Alright, this issue and another similar one I've got are fixed upstream: https://github.com/jaymzh/pius/commit/79d096eea73b40ae97f91140bb2282eebfcf0d2f and https://github.com/jaymzh/pius/commit/325b1fbb76bb45e852f6ef86feb52a79c2ff702f

I'll poke upstream to release a new minor version with these changes.

allspark commented on 2015-12-01 19:52

using local/gnupg 2.1.9-1.

don't know the format of my keyring ?!

zorun commented on 2015-11-29 14:27

Strange, it works here.

What version of gnupg are you using? What is the format of your public/private keyring?

allspark commented on 2015-11-24 19:34

hi, thx for updating.
i'm starting pius, entering my email server password, then the gpg-pinentry dialog opens.
after entering the passphrase i'm getting this:

File "/usr/bin/pius", line 333, in <module>
main()
File "/usr/bin/pius", line 317, in main
if signer.sign_all_uids(key, retval):
File "/usr/lib/python2.7/site-packages/libpius/signer.py", line 781, in sign_all_uids
self.mailer.send_sig_mail(self.signer, key, uid, self)
File "/usr/lib/python2.7/site-packages/libpius/mailer.py", line 225, in send_sig_mail
signer, uid_data['email'], keyid, uid_data['file'], psign
File "/usr/lib/python2.7/site-packages/libpius/mailer.py", line 175, in _generate_pgp_mime_email
psigner.encrypt_and_sign_file(tmpfile, signed_tmpfile, keyid)
File "/usr/lib/python2.7/site-packages/libpius/signer.py", line 876, in encrypt_and_sign_file
raise EncryptionUnknownError(line)
libpius.exceptions.EncryptionUnknownError: [GNUPG:] PINENTRY_LAUNCHED 10282

zorun commented on 2015-11-22 23:51

Updated to 2.2.1, and switched to github. It should now work out-of-the-box with gnupg2, please report any issue.

zorun commented on 2015-04-15 15:25

Thanks, updated :)

encbladexp commented on 2015-04-15 14:48

I disowned it, feel free ;)

zorun commented on 2015-04-15 14:44

Here is a new version, with a patch to work correctly with gpg 2.1 (gpg-agent change):

http://pub.polyno.me/arch/pius-2.1.1-3.src.tar.gz
http://pub.polyno.me/arch/pius-2.1.1-3.src.tar.gz.sig

zorun commented on 2015-04-15 10:05

Version 2.1.0 introduced libpius, with is not installed by the current PKGBUILD, so pius doesn't work ("ImportError: No module named libpius").

Here is a corrected PKGBUILD and patch, also updated to pius 2.1.1:

http://pub.polyno.me/arch/pius-2.1.1-1.src.tar.gz
http://pub.polyno.me/arch/pius-2.1.1-1.src.tar.gz.sig

I can adopt this package if you don't have time, btw.

All comments