Package Details: pivx-qt 3.1.1-1

Git Clone URL: https://aur.archlinux.org/pivx.git (read-only)
Package Base: pivx
Description: Transactional security and privacy-focused decentralized open source cryptocurrency (Qt)
Upstream URL: https://pivx.org/
Licenses: MIT
Submitter: aaronm-cloudtek
Maintainer: aaronm-cloudtek
Last Packager: aaronm-cloudtek
Votes: 10
Popularity: 0.134852
First Submitted: 2017-03-19 10:49
Last Updated: 2018-07-16 02:31

Latest Comments

aaronm-cloudtek commented on 2017-10-10 01:03

Since there are still upstream issues with the build process I have updated the package to use the pre-compiled binaries for now.

aaronm-cloudtek commented on 2017-05-10 05:49

I updated the package to the latest 2.2.1 though it still won't compile until the OpenSSL compatibility issue is fixed.

aaronm-cloudtek commented on 2017-05-02 23:06

@jinglejungle,

There is a compatibility issue with the latest OpenSSL: https://github.com/PIVX-Project/PIVX/issues/149

I recommend using upstream's pre-compiled binaries until it is fixed.

jinglejungle commented on 2017-05-02 09:53

Hi Aaron, community,

i get this error:
---------------
checking for RAND_egd in -lcrypto... no
configure: error: Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
==> FEHLER: Ein Fehler geschah in build().
Breche ab...
==> FEHLER:Makepkg konnte pivx nicht erstellen.
==> Erstellen von pivx-cli neu starten?[j/N]
==> ----------------------------------------
==>

---------------

What's wrong?

BR
JJ

aaronm-cloudtek commented on 2017-04-03 04:47

Thanks @ccoder, I updated the package.

ccoder commented on 2017-03-28 21:50

Hi AaronM,

on my system i also needed to install 'qt5-tools' to build, maybe you are missing a dependency.

g ccoder