Package Details: pkgbrowser 0.28-3

Git Clone URL: (read-only, click to copy)
Package Base: pkgbrowser
Description: A utility for browsing pacman databases and the AUR
Upstream URL:
Licenses: GPL2
Submitter: kachelaqa
Maintainer: kachelaqa
Last Packager: kachelaqa
Votes: 282
Popularity: 2.70
First Submitted: 2011-04-20 18:18 (UTC)
Last Updated: 2024-03-17 13:23 (UTC)

Latest Comments

1 2 3 4 5 6 .. 18 Next › Last »

burster commented on 2024-03-17 00:42 (UTC) (edited on 2024-03-17 00:42 (UTC) by burster)

@siliconmeadow: Thanks, too.

@galvez_65: Yes, it does.

galvez_65 commented on 2024-03-16 20:41 (UTC)

@siliconmeadow thank you your patch looks like its working

siliconmeadow commented on 2024-03-16 16:53 (UTC)

Patch to work with pacman 6.1:

diff --git a/PKGBUILD b/PKGBUILD
index 80ff458..d3f22a5 100644
@@ -7,7 +7,7 @@ pkgdesc='A utility for browsing pacman databases and the AUR'
-depends=('pacman>=4.1' 'pacman<6.1' 'python>=3.2' 'python<3.12' 'python-pyqt5')
+depends=('pacman>=4.1' 'pacman<6.2' 'python>=3.2' 'python<3.12' 'python-pyqt5')

rafaelff commented on 2024-03-15 02:26 (UTC)

Heads up: pacman 6.1.0-2 in testing repo and should land in stable soon, and this package depends on pacman<6.1.

friday13 commented on 2023-10-15 15:27 (UTC)

==> ERROR: Failure while downloading

nimbusflow commented on 2023-05-31 23:53 (UTC)

Just a quick note to let you know that I looked into this again last week and was able to fix it.

Before trying your suggestions, I tried rebuilding pkgbrowser once again but this time I made sure I cleared my local cache first (yay -Scc). Not sure I had done it before to be honest. All good now, thanks for your help!

nimbusflow commented on 2023-05-12 21:11 (UTC) (edited on 2023-05-12 21:12 (UTC) by nimbusflow)

(sorry both, can't test any of the suggestions at the moment)

@rafaelff: thanks - literally the first thing I tried, before my first post even!

@kachelaqa: cool, thanks. For the record, I just was saying the justification you provided didn't apply in my case (because I did the exact opposite), not the actual suggested fix. For the sake of clarity, the sequence I went through last week before posting my first comment was 'upgrade pkgbrowser' -> 'full system upgrade' -> 'reinstall pkgbrowser' (after realising it wasn't working)

rafaelff commented on 2023-05-12 19:57 (UTC)

Yeah, first perform a full system upgrade (-Syu) and then rebuild pkgbrowser

kachelaqa commented on 2023-05-12 19:31 (UTC)

@nimbusflow Actually, it does apply, because either way you'll end up with a compiled extension (alpm) that is built for the wrong version of python. That's why you see the exception ImportError: cannot import name 'alpm'.

nimbusflow commented on 2023-05-12 18:04 (UTC) (edited on 2023-05-12 18:04 (UTC) by nimbusflow)

@rafaelff: thanks, I'll give that a try. I should have been clearer, I only deleted what was relevant to pkgbrowser. No other files were harmed in the debugging of this package!

@kachelaqa: I had to upgrade pkgbrowser before I upgraded python as the 3.10 dependency was stopping me from updating my system, so your suggestion doesn't apply to my case. I'll check /usr/lib/pkgbrowser/ anyway though, thanks.