Package Details: pkgbrowser 0.21-3

Git Clone URL: https://aur.archlinux.org/pkgbrowser.git (read-only)
Package Base: pkgbrowser
Description: A utility for browsing pacman databases and the AUR
Upstream URL: https://bitbucket.org/kachelaqa/pkgbrowser
Licenses: GPL2
Submitter: kachelaqa
Maintainer: kachelaqa
Last Packager: kachelaqa
Votes: 271
Popularity: 2.054270
First Submitted: 2011-04-20 18:18
Last Updated: 2018-08-06 15:44

Latest Comments

1 2 3 4 5 6 ... Next › Last »

indianahorst commented on 2018-09-02 14:55

Thanks! It works again after rebuilding!

kachelaqa commented on 2018-09-01 10:48

@indianahorst It's not a dependency - you need to rebuild.

indianahorst commented on 2018-09-01 09:27

Any dependency seems to be missing:


$ pkgbrowser 
Traceback (most recent call last):
  File "/usr/lib/pkgbrowser/main.py", line 9, in <module>
    sys.exit(app.run())
  File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 112, in run
    app.window().setup()
  File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 56, in window
    from pkgbrowser.window import Window
  File "/usr/lib/pkgbrowser/pkgbrowser/window.py", line 18, in <module>
    from pkgbrowser.backend import (
  File "/usr/lib/pkgbrowser/pkgbrowser/backend.py", line 13, in <module>
    from pkgbrowser import alpm, conf, utils
ImportError: cannot import name 'alpm' from 'pkgbrowser' (/usr/lib/pkgbrowser/pkgbrowser/__init__.py)
</module></module></module>

Could you please add the required dependency?

Kr1ss commented on 2018-08-06 14:11

I've just built the package with the python dependency changed to 'python<3.8'. Building and running without issues so far.

stef204 commented on 2018-08-06 14:02

"installing python (3.7.0-3) breaks dependency 'python<3.7' required by pkgbrowser"
Can you please check into it/update, etc.?

rafaelff commented on 2018-05-29 14:07

@keepitsimpleengr: uninstall pkgbrowser, update pacman, install pkgbrowser again.

keepitsimpleengr commented on 2018-05-29 13:35

pkgbrowser: installing pacman (5.1.0-1) breaks dependency 'pacman<5.1'

so "pacman<5.2 (pacman-buildenv_ext-git, pacman-git)" seems in error

slav commented on 2018-05-29 11:53

@siliconmeadow - thank you

confirmed, adding below line: depends=('pacman>=4.1' 'pacman<5.1' 'python>=3.2' 'python<3.7' 'python-pyqt5')

resolving pacman dependency issue

siliconmeadow commented on 2018-05-29 07:36

I just did a tweak of PKGBUILD and it seems ok with Pacman 5.1.

diff --git a/PKGBUILD b/PKGBUILD
index 7aa8bb8..1f42720 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='A utility for browsing pacman databases and the AUR'
 arch=('x86_64')
 url="https://bitbucket.org/kachelaqa/$pkgname"
 license=('GPL2')
-depends=('pacman>=4.1' 'pacman<5.1' 'python>=3.2' 'python<3.7' 'python-pyqt5')
+depends=('pacman>=4.1' 'pacman<5.2' 'python>=3.2' 'python<3.7' 'python-pyqt5')
 install="$pkgname.install"
 source=("$url/downloads/$pkgname-$pkgver.tar.gz")
 md5sums=('5f5be024e6f5256ea4ba744341a55767')

lpc123 commented on 2018-05-29 01:02

Will this package be upgraded to support Pacman v5.1.0 - libalpm v11.0.0?