Package Details: pkgbrowser 0.22-2

Git Clone URL: (read-only, click to copy)
Package Base: pkgbrowser
Description: A utility for browsing pacman databases and the AUR
Upstream URL:
Licenses: GPL2
Submitter: kachelaqa
Maintainer: kachelaqa
Last Packager: kachelaqa
Votes: 273
Popularity: 0.39
First Submitted: 2011-04-20 18:18
Last Updated: 2019-11-14 22:19

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

kachelaqa commented on 2018-09-01 10:48

@indianahorst It's not a dependency - you need to rebuild.

indianahorst commented on 2018-09-01 09:27

Any dependency seems to be missing:

$ pkgbrowser 
Traceback (most recent call last):
  File "/usr/lib/pkgbrowser/", line 9, in <module>
  File "/usr/lib/pkgbrowser/pkgbrowser/", line 112, in run
  File "/usr/lib/pkgbrowser/pkgbrowser/", line 56, in window
    from pkgbrowser.window import Window
  File "/usr/lib/pkgbrowser/pkgbrowser/", line 18, in <module>
    from pkgbrowser.backend import (
  File "/usr/lib/pkgbrowser/pkgbrowser/", line 13, in <module>
    from pkgbrowser import alpm, conf, utils
ImportError: cannot import name 'alpm' from 'pkgbrowser' (/usr/lib/pkgbrowser/pkgbrowser/

Could you please add the required dependency?

Kr1ss commented on 2018-08-06 14:11

I've just built the package with the python dependency changed to 'python<3.8'. Building and running without issues so far.

stef204 commented on 2018-08-06 14:02

"installing python (3.7.0-3) breaks dependency 'python<3.7' required by pkgbrowser"
Can you please check into it/update, etc.?

rafaelff commented on 2018-05-29 14:07

@keepitsimpleengr: uninstall pkgbrowser, update pacman, install pkgbrowser again.

keepitsimpleengr commented on 2018-05-29 13:35

pkgbrowser: installing pacman (5.1.0-1) breaks dependency 'pacman<5.1'

so "pacman<5.2 (pacman-buildenv_ext-git, pacman-git)" seems in error

slav commented on 2018-05-29 11:53

@siliconmeadow - thank you

confirmed, adding below line: depends=('pacman>=4.1' 'pacman<5.1' 'python>=3.2' 'python<3.7' 'python-pyqt5')

resolving pacman dependency issue

siliconmeadow commented on 2018-05-29 07:36

I just did a tweak of PKGBUILD and it seems ok with Pacman 5.1.

diff --git a/PKGBUILD b/PKGBUILD
index 7aa8bb8..1f42720 100644
@@ -7,7 +7,7 @@ pkgdesc='A utility for browsing pacman databases and the AUR'
-depends=('pacman>=4.1' 'pacman<5.1' 'python>=3.2' 'python<3.7' 'python-pyqt5')
+depends=('pacman>=4.1' 'pacman<5.2' 'python>=3.2' 'python<3.7' 'python-pyqt5')

lpc123 commented on 2018-05-29 01:02

Will this package be upgraded to support Pacman v5.1.0 - libalpm v11.0.0?

rafaelff commented on 2017-02-15 02:22

xdg-icon-resources is just a wrapper around gtk-update-icon-cache, which is already provided as hook for pacman (FS#49116). You may safely remove the .install file.

On the other hand, package 'hicolor-icon-theme' is reported by `namcap' as a dependency for this package. Consider adding it to depends()