Package Details: planetary-annihilation 86765-1

Git Clone URL: (read-only)
Package Base: planetary-annihilation
Description: RTS gameplay in a way that's never been seen before.
Upstream URL:
Keywords: game rts
Licenses: custom
Conflicts: planetary-annihilation-pte
Submitter: hobarrera
Maintainer: hobarrera
Last Packager: hobarrera
Votes: 4
Popularity: 0.000000
First Submitted: 2013-06-18 05:42
Last Updated: 2015-09-04 19:21

Latest Comments

nloewen commented on 2014-08-10 04:22

build: 70289
md5sum: ef70b31d0e75187ddf2c660c2b29aafe

BoLLo commented on 2014-06-05 02:05

23f2095e12e3d827c61c8075a822cb0b PA_Linux_66943.tar.bz2

Turns out was looking for CoherentUI_Host.bin which wasn't there. I copied the one from the Steam sandbox. I'm not sure if this is a good idea or not but it runs.

BoLLo commented on 2014-06-04 08:07

f2a4a0b2ed6a60bb3372a073f803a6ec PA_Linux_66830.tar.bz2

This one blank screens for me whereas 66567 (and 66830 in Steam sanbox) did/does not. I wish I knew how to find out why.

hobarrera commented on 2014-05-31 16:16

For those interested: planetary-annihilation-pte is a cli launcher that lets you pick between the stable channel, and the PTE channel. The latter contains newer code (and some fixes with open source drivers/intel cards).

hobarrera commented on 2014-05-30 12:18

@mcxplode I gave it a try[1], but the launcher is broken and assumes there's local native IPv4 connectivity:

$ go run /opt/PA-pte/papatcher.go
setting GOMAXPROCS to 4
Ubername: hobarrera
Password: AlmostForgotToDeleteIt!
logging in...
Could not contact
Post dial tcp network is unreachable
exit status 1


mcxplode commented on 2014-05-30 05:54

Lol would be nice to have separate hacked launcher to update PA files from archive.
SXX posted something about using William.

"If dependency on golang isn't bug problem you can integrate William launcher in it I think."

hobarrera commented on 2014-05-29 05:56

@mcxplode Thanks! Regarding not recompressing everything, I don't think it'll be possible unless I use some nasty hack that requires the package AND the tarball together at install time (planetary-annihilation.install would do the moving). But it's too hackish and pacman won't track file ownership if I do so.

mcxplode commented on 2014-05-29 04:00

nice shiny build for Arch, now only thing to figure out is magic trick where you don't have to extract files from PA bz2 archive then recompress them into xz archive. PA build getting damn big.

hobarrera commented on 2014-05-29 02:52

@mcxplode: Huh, hadn't noticed that. Fixed. :)

mcxplode commented on 2014-05-29 00:02

New build includes libcurl in Steam Runtime.
Might want to check what other static libs are included too as to not include libs and dependencies that are not needed.

hobarrera commented on 2014-05-28 15:08

Moved the specific version of curl onto a different package to avoid rebuilding on every update.

N30N commented on 2014-05-16 17:35

optdepends=("pamm: for mod manager")

BoLLo commented on 2014-03-30 11:42

b0815518e336dcb45d88fa88442cc97e PA_Linux_63475.tar.bz2

hobarrera commented on 2014-02-13 03:36

czarkoff: That's, I merged several of those fixes. :)

czarkoff commented on 2014-01-02 04:14

Here's updated package:

I made it without knowing about this one, so it is a bit different and follows another versioning scheme (I did simply reuse build numbers). The package is for build 58772, and it additionaly works around issues with opensource drivers. It lacks launcher script, though it adds freedesktop launcher with icon.

Regarding rtmpdump - it is dependency of libcurl, so rebuilding package on rtmpdump is sufficient.

pdxleif commented on 2014-01-01 09:09

Also, the new rtmpdump-20131205 doesn't work. You need the older package, version 20121230 or something.

Kant commented on 2013-12-29 19:48

Yet another one:
165b47b97671a0467feb58b810b5b981 PA_Linux_58772.tar.bz2

jasperwoudenberg commented on 2013-11-27 19:59

And another one:
af5d6d4092594295aa05f9c8bdf478e7 PA_Linux_57703.tar.bz2

Kant commented on 2013-11-23 01:24

new release:
68758114f40a6491ee24e123fd2044f4 PA_Linux_57449.tar.bz2

exterm commented on 2013-10-05 09:28

are you downloading curl in the PKGBUILD? why not just depend on the package?

Big-B commented on 2013-09-01 21:30

Update for 52512?

swiftgeek commented on 2013-06-20 15:02

Patches should be just commented, but included in PKGBUILD ;)
It's just JavaScript after all, and helps a lot when game crashes
(next thing would be autologin (done here but ugly) and changing default screen to "ubernet games")

And there is automated way to even check version against upstream (with simple daemon using curl) and mark package to be upgraded on next yaourt -Syua ;) (pkgver down to 0)

But daemon makes no sense here since almost always there are couple of builds out between times I play :)

hobarrera commented on 2013-06-20 07:44

I've added your changes and the package works again. It's a shame there's no automated way to retrieve upstream packages, otherwise I'd implement something that did that (even if it means asking for username/password).

I haven't looked at your latest patch yet, and I'm not sure if it's a good idea to include it. I'm not sure if packages where files have been modified are redistributable.

swiftgeek commented on 2013-06-20 04:15

Updated against freshest

swiftgeek commented on 2013-06-20 04:09

TODO: Make usernames in chat at least bold, hopefully with different color

swiftgeek commented on 2013-06-20 03:56

Patch to disable that stupid warning:

swiftgeek commented on 2013-06-20 03:39

Also patch to disable that stupid warning it's on its way ;)

swiftgeek commented on 2013-06-20 03:38
I can overmaintain this package ;)

Eg. it's possible to add auto-updater like git and humble bundles, at least for now ;)

hobarrera commented on 2013-06-20 03:33

Yeah, something broke in one of the last updates I made to it. Not sure what. I'll take a look at it when I've the time. Meanwhile, patches are welcome.

swiftgeek commented on 2013-06-20 02:49

I will try to fix this PKGBUILD in 48h ;)

swiftgeek commented on 2013-06-19 16:59

works from $srcdir but not installed :( 49731