Package Details: plank-theme-pantheon-bzr r614-1

Git Clone URL: https://aur.archlinux.org/gtk-theme-elementary-bzr.git (read-only)
Package Base: gtk-theme-elementary-bzr
Description: Pantheon Plank theme
Upstream URL: https://launchpad.net/egtk
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: plank-theme-pantheon
Provides: plank-theme-pantheon
Submitter: fresh24
Maintainer: alucryd
Last Packager: alucryd
Votes: 56
Popularity: 0.824447
First Submitted: 2013-09-01 19:27
Last Updated: 2015-12-20 10:21

Latest Comments

alucryd commented on 2016-03-10 07:53

Installing the supported way, which is makepkg, has always installed both packages without asking. If you're using a helper, you're on your own.

rcct commented on 2016-03-07 23:00

As of late when updating the package, instead of asking like before, plank-theme-pantheon-bzr is installed too by default.

Is there a way to avoid this?

rcct commented on 2015-10-15 23:44

Right now version 542 is available and this time I went to the tmp folder in order to see what was going on there.

As far as I understand it the problem is in the following line of the PKGBUILD,

cp -dr --no-preserve='ownership' gtk-2.0 gtk-3.0 metacity-1 index.theme "${pkgdir}"/usr/share/themes/elementary/

According to the folder listing in the build (src) folder there is no (longer?) metacity-1 folder created and thus can not be copied either. This seems to happen from version 536 (see previous message) onward.
I don't know what the "consequences" of this removal may be in order to be able to accurately use this theme.

It seems a major "issue" thus I will flag the package as out-of-date for now until the PKBUILD is fixed.

rcct commented on 2015-10-13 22:15

When updating to 536 I get the following error and, subsequently, the package is not updated:

==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package_gtk-theme-elementary-bzr()...
cp: cannot stat 'metacity-1': No such file or directory
==> ERROR: A failure occurred in package_gtk-theme-elementary-bzr().
Aborting...
==> ERROR: Makepkg was unable to build gtk-theme-elementary-bzr.

rcct commented on 2015-04-17 20:13

Just updated to 448-1 and was asked during the process if I only wanted to install the gtk-theme-elementary-bzr package which is what I use.
I presume that, just as you state, it would update the plank-theme-pantheon-bzr package too if I had it installed and as I do not it asks me if I want to just stick to what I do have.

Therefore, as far as I understand it, all is working as it should. Thanks for the heads-up.

alucryd commented on 2015-04-17 07:27

It is a split package, so yeah it is safe. Depending on how you build it you may have plank-theme-pantheon-bzr installed at the same time.

rcct commented on 2015-04-17 00:06

Since the new PKGBUILD I am receiving the following notification during the update process for this package,

This PKGBUILD describes a split package.

Is it safe to ignore it for the package version/name I use (gtk-theme-elementary-bzr) will update as usual?

alucryd commented on 2015-04-16 07:15

Thx!

veeti commented on 2015-04-15 15:55

Sure thing! Thanks for all the work on packaging Pantheon. Disowned.

alucryd commented on 2015-04-15 14:08

Hey, would you mind if I took over this package? I'm already maintaining almost everything related to Pantheon, and egtk now ships the Pantheon theme for Plank as well, so I made a split PKGBUILD for that. You can find it here: https://github.com/alucryd/aur-alucryd/tree/master/pantheon/gtk-theme-elementary-bzr

All comments