Package Details: planner 0.14.6-6

Git Clone URL: https://aur.archlinux.org/planner.git (read-only, click to copy)
Package Base: planner
Description: Project management application for GNOME
Upstream URL: https://wiki.gnome.org/Apps/Planner
Licenses: GPL
Submitter: xyproto
Maintainer: invictus
Last Packager: xyproto
Votes: 0
Popularity: 0.000000
First Submitted: 2019-03-27 09:22
Last Updated: 2019-03-27 09:22

Latest Comments

travjp commented on 2020-07-11 04:19

This fixed the `_PyGObject_API' error for me:

$ diff -u a/PKGBUILD b/PKGBUILD 
--- a/PKGBUILD  2020-07-10 22:53:31.923056196 -0500
+++ b/PKGBUILD  2020-07-10 22:56:39.155453615 -0500
@@ -52,8 +52,7 @@
   cd $pkgname-$pkgver
   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
               --disable-update-mimedb --disable-schemas-install \
-              --with-gconf-schema-file-dir=/usr/share/gconf/schemas \
-              PYTHON=/usr/bin/python2
+              --with-gconf-schema-file-dir=/usr/share/gconf/schemas

   #https://bugzilla.gnome.org/show_bug.cgi?id=656231
   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool

micman commented on 2020-06-25 18:18

Hi! In am not able to install PLANNER.

/usr/bin/ld: .libs/plannerui_la-plannerui.o:(.bss+0x0): multiple definition of `_PyGObject_API'; .libs/plannerui_la-planneruimodule.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:523: plannerui.la] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/home/compx/.cache/yay/planner/src/planner-0.14.6/python'
make[1]: *** [Makefile:574: all-recursive] Error 1
make[1]: Leaving directory '/home/compx/.cache/yay/planner/src/planner-0.14.6'
make: *** [Makefile:483: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

Some idea?

[I am working on Manjaro XFCE4.]