Package Details: plasma-browser-integration-git 5.22.80_r1254.gcedda05a-1

Git Clone URL: https://aur.archlinux.org/plasma-browser-integration-git.git (read-only, click to copy)
Package Base: plasma-browser-integration-git
Description: Components necessary to integrate browsers into the Plasma Desktop
Upstream URL: https://www.kde.org/plasma-desktop
Licenses: GPL
Conflicts: plasma-browser-integration
Provides: plasma-browser-integration
Submitter: arojas
Maintainer: IslandC0der (chaotic-aur)
Last Packager: IslandC0der
Votes: 25
Popularity: 0.000590
First Submitted: 2017-05-04 18:12 (UTC)
Last Updated: 2021-05-30 18:02 (UTC)

Latest Comments

francoism90 commented on 2018-05-19 16:56 (UTC)

Going to disown this again - upstream now provides releases: https://aur.archlinux.org/packages/plasma-browser-integration/

arojas commented on 2018-05-16 09:34 (UTC)

It did make sense up until 1 hour ago

https://cgit.kde.org/plasma-browser-integration.git/commit/?id=9d6056c5e6ca531869cbd924b0b3d89a184ad3ca

And why is it dangerous?

dvogel commented on 2018-05-16 09:32 (UTC)

The use of mv in the package phase does not make much sense to me... and seems dangerous.

simona commented on 2018-05-08 19:03 (UTC)

Ok. Thanks very much.

arojas commented on 2018-05-08 17:05 (UTC)

Nothing is safe to install if you do stupid things like --force

simona commented on 2018-05-08 17:03 (UTC)

It is now safe to install? Are you sure?

nfs commented on 2018-05-03 16:22 (UTC)

@arojas: It's working perfectly now that it's writing to /usr/lib instead of /lib and /usr/bin instead of /bin. Thanks for taking the time to fix it!

arojas commented on 2018-05-03 06:31 (UTC)

@nfs try now

nfs commented on 2018-05-03 00:54 (UTC) (edited on 2018-05-03 00:56 (UTC) by nfs)

@arojas Here's the link to the compilation output: https://ptpb.pw/xRvf

The package seems to build all right, but installing it results in complaints:

    /bin exists in filesystem
    /lib exists in filesystem

Hope this helps.

arojas commented on 2018-05-02 21:17 (UTC)

@nfs please pastebin the full compilation output

nfs commented on 2018-05-02 21:15 (UTC)

Unfortunately, I don't know enough about creating packages to understand why the package won't install. I did learn that by following the folder structure of the built package, I could manually place the files in corresponding folders, and after restarting the machine, I had the expected functionality. This is a pretty tedious solution, of course.

simona commented on 2018-04-29 19:04 (UTC)

I have installed with --force doing big damage to root install.

nfs commented on 2018-04-28 16:59 (UTC) (edited on 2018-05-01 01:28 (UTC) by nfs)

After building successfully, the package won't upgrade on my system when I use "makepkg -i" or "pacman -U" on the built package. I get the following errors:

 error: failed to commit transaction (conflicting files)
 plasma-browser-integration-git: /bin exists in filesystem
 plasma-browser-integration-git: /lib exists in filesystem
 plasma-browser-integration-git: /lib/mozilla/native-messaging-hosts/org.kde.plasma.browser_integration.json exists in filesystem
 Errors occurred, no packages were upgraded.

I'm not quite sure what to do, since removing /bin and /lib isn't really an option. I uninstalled and tried again, but that just eliminated the org.kde.plasma.browser_integration.json message. The complaints about /bin and /lib are still there, and it won't install.

This is happening on 3 different machines with Arch installed.

mareex commented on 2018-04-28 09:40 (UTC)

Package error in r262.e1b70f9-1:

Install the project... -- Install configuration: "Release" -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/etc/chromium/native-messaging-hosts/org.kde.plasma.browser_integration.json -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/etc/opt/chrome/native-messaging-hosts/org.kde.plasma.browser_integration.json -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/usr/bin/../lib/mozilla/native-messaging-hosts/org.kde.plasma.browser_integration.json -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/usr/bin/plasma-browser-integration-host -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/usr/lib/qt/plugins/krunner_browsertabs.so -- Installing: /home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/usr/share/kservices5/plasma-runner-browsertabs.desktop mv: cannot stat '/home/marcus/.cache/pacaur/plasma-browser-integration-git/pkg/plasma-browser-integration-git/usr/share/chromium-browser': No such file or directory ==> ERROR: A failure occurred in package().

arojas commented on 2018-03-10 10:01 (UTC) (edited on 2018-03-10 10:02 (UTC) by arojas)

@Thaodan google-chrome != chromium

Thaodan commented on 2018-03-09 23:00 (UTC)

should the data for chromium really go to /opt? Chromium is installed into /usr.