Package Details: plasma-wayland-session-git 5.24.80_r11429.g43ca3339b-1

Git Clone URL: https://aur.archlinux.org/plasma-workspace-git.git (read-only, click to copy)
Package Base: plasma-workspace-git
Description: Plasma Wayland session
Upstream URL: https://kde.org/plasma-desktop/
Licenses: LGPL
Conflicts: plasma-wayland-session
Provides: plasma-wayland-session
Submitter: arojas
Maintainer: IslandC0der (chaotic-aur)
Last Packager: IslandC0der
Votes: 7
Popularity: 0.017747
First Submitted: 2014-03-31 06:31 (UTC)
Last Updated: 2022-02-22 20:08 (UTC)

Latest Comments

1 2 3 4 5 Next › Last »

davispuh commented on 2022-03-19 16:48 (UTC)

I hit same issue, was pretty confusing :D but thanks <3 works great :)

cniw commented on 2022-02-26 22:12 (UTC)

@IslandC0der oh I see, thanks for the response and explanation

IslandC0der commented on 2022-02-22 20:07 (UTC) (edited on 2022-02-22 20:10 (UTC) by IslandC0der)

@cniw Sorry for the late response, but that's the way it is on the official PKGBUILD

When building plasma-workspace for the first time, you can use the -d flag with makepkg to ignore that missing dependency. I can't simply remove it from the dependency list, since it is indeed a dependency.

It would be nice if we could add runtime-only dependencies, as it isn't required when building, but sadly such a feature does not exist.

cniw commented on 2022-02-08 07:06 (UTC)

Can't build because of loop depends issue with kde-cli-tools-git package, kde-cli-tools-git has plasma-workspace-git in its makedepends list.

CMake Error at CMakeLists.txt:61 (find_package):
  Could not find a configuration file for package "LibKWorkspace" that is
  compatible with requested version "5.24.80".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.21.80
    /usr/lib/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.21.80
    /lib64/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.21.80
    /lib/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.21.80

plasma-workspace-git package should build first before kde-cli-tools-git package, so kde-cli-tools-git should removed from plasma-workspace-git depends list

IslandC0der commented on 2021-09-09 21:48 (UTC)

Yup, it will :)

Xwang commented on 2021-09-09 20:27 (UTC)

If I build and install this package will the patch which fixes this bug be already present: https://bugs.kde.org/show_bug.cgi?id=438874

The fix is said to be made in 5.23

IslandC0der commented on 2021-01-16 22:43 (UTC)

Thank you @cniw!

cniw commented on 2021-01-12 09:48 (UTC) (edited on 2021-01-12 09:50 (UTC) by cniw)

'plasma-wayland-protocols' or 'plasma-wayland-protocols-git', must be added in makedepends list

CMake Error at CMakeLists.txt:127 (find_package):
  By not providing "FindPlasmaWaylandProtocols.cmake" in CMAKE_MODULE_PATH
  this project has asked CMake to find a package configuration file provided
  by "PlasmaWaylandProtocols", but CMake did not find one.

  Could not find a package configuration file provided by
  "PlasmaWaylandProtocols" with any of the following names:

    PlasmaWaylandProtocolsConfig.cmake
    plasmawaylandprotocols-config.cmake

  Add the installation prefix of "PlasmaWaylandProtocols" to
  CMAKE_PREFIX_PATH or set "PlasmaWaylandProtocols_DIR" to a directory
  containing one of the above files.  If "PlasmaWaylandProtocols" provides a
  separate development package or SDK, be sure it has been installed.

AlD commented on 2020-02-22 15:23 (UTC)

Did some cleanups and orphaned this again.

lav1968 commented on 2019-08-14 15:17 (UTC)

Replace startkde with startplasma-x11 in PKGBUILD.