Package Details: plasma-workspace-git r4154.a84e771-2

Git Clone URL: https://aur.archlinux.org/plasma-workspace-git.git (read-only)
Package Base: plasma-workspace-git
Description: KDE Plasma Workspace
Upstream URL: https://projects.kde.org/projects/kde/kde-workspace
Licenses: LGPL
Groups: plasma
Conflicts: drkonqi, kdebase-workspace, plasma-workspace
Provides: drkonqi, plasma-workspace
Submitter: arojas
Maintainer: None
Last Packager: Alad
Votes: 5
Popularity: 0.000092
First Submitted: 2014-03-31 06:31
Last Updated: 2016-06-24 02:00

Required by (35)

Sources (1)

Latest Comments

Soukyuu commented on 2016-05-12 19:20

any reason why networkmanager-qt (and some others) is a hard dependency vs. make dependency on "stable" plasma-workspace? I really hope I won't be forced to install networkmanager next plasma release...

Alad commented on 2016-05-03 08:00

Added, thanks

arojas commented on 2016-05-03 07:55

new dependency: kholidays

hepha commented on 2016-04-21 06:23

hello
Please edit the following
provides=(plasma-workspace drkonqi)
to
provides=(plasma-workspace drkonqi kdebase-runtime kuiserver)


arojas commented on 2015-02-25 16:01

@mixedCase update all -git dependencies first.

mixedCase commented on 2015-02-25 15:56

Not compiling for me:

http://pastebin.com/KVVu4CSK

And yes, I've tried without an AUR helper too.

tajidinabd commented on 2015-02-09 22:12

plasma-workspace-git E: Dependency prison-frameworks-git detected and not included (libraries ['usr/lib/libKF5Prison.so.1'] needed in files ['usr/lib/qt/plugins/plasma/dataengine/plasma_engine_clipboard.so', 'usr/lib/libkdeinit5_klipper.so'])

anex commented on 2015-01-16 11:57

ok makes sense, thx arojas

arojas commented on 2015-01-16 11:56

@anex cmake already displays a list of dependencies before starting compilation. Adding every single dependency to all KF5 based packages would make the dependency list unreadable, Plasma packages for instance depend on basically every single framework. You're probably better off rebuilding in a clean chroot so that all deps are automatically updated.

anex commented on 2015-01-16 11:37

im just referring to someone looking at the make depends and then they can make sure they are up to date but if the make depend is not even listed how is a person suppose to know

arojas commented on 2015-01-16 11:35

@anex that wouldn't help with your issue. git packages are never automatically updated to the latest revision regardless of whether they are explicitely listed in depends or not. It is the user's job to keep the git packages up to date.

anex commented on 2015-01-16 11:29

@ arojas,

Can you add solid-git to make depends please..

reference:

https://bugs.kde.org/show_bug.cgi?id=342901

arojas commented on 2015-01-06 08:39

@anex upstream issue http://build.kde.org/job/plasma-workspace_master_qt5/1184/console

anex commented on 2015-01-06 08:21

Im getting a build error arojas.. ?


-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:13 (set_package_properties):
Unknown CMake command "set_package_properties".


-- Configuring incomplete, errors occurred!
See also "/home/anex/yaourt/yaourt-tmp-root/aur-plasma-workspace-git/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build plasma-workspace-git.
==> Restart building plasma-workspace-git ? [y/N]
==> ---------------------------------------------
==>

AnAkkk commented on 2014-09-14 21:21

Same issue for plasma-nm-git BTW.

arojas commented on 2014-09-14 21:20

@AnAkkk yes, I thought the QML_INSTALL_DIR option was not needed anymore with the new KDE_INSTALL_USE_QT_SYS_PATHS flag, but apparently it still is.

AnAkkk commented on 2014-09-14 21:03

Actually the issue seem to only be related to plasma-workspace-git, it's totally fixed after modifying it.

AnAkkk commented on 2014-09-14 20:55

I have many QML errors since some packages were updated, plasma is broken.
I could fix a few of them by adding -DQML_INSTALL_DIR=lib/qt/qml to this PKGBUILD, but I'm not sure if it should be removed from all of them or added to all of them.

arojas commented on 2014-08-06 18:48

@KlavKalashj my bad, sorry. Fixed now

KlavKalashj commented on 2014-08-06 13:54

I uncommented this line in the PKGBUILD:

# sed 's:/opt/kf5/lib/libexec/kf5/start_kdeinit_wrapper:/usr/lib/libexec/kf5/start_kdeinit_wrapper:' -i "$pkgdir"/opt/kf5/bin/startkde

and it works again.

KlavKalashj commented on 2014-08-06 11:48

Plasma-desktop does not start after last update. Something wrong with start_kdeinit_wrapper, I think. File seems to be missing or something.

gyan000 commented on 2014-07-16 11:49

Hi,

KDE4 neither KF5 seems to like GDM so I installed KDM. (from kdebase-workspace)
It was not working with KDM, but I found this solution on google.

Thanks.

arojas commented on 2014-07-16 10:54

@gyan000 which DM are you using?

gyan000 commented on 2014-07-16 10:18

Hello,

Just to let you know, from my side, to be able to login successfully into plasma 5 I had to copy services files from /opt/kf5/share/dbus-1/services/* into /usr/share/dbus-1/services/.
Without that some services like kglobalaccel were not started and so the plasma 5 session was frozen.

Thanks.

arojas commented on 2014-07-10 06:23

@enoop It should already be built with dbusmenu support, it has libdbusmenu-qt5 in the dependency chain. Note that the appmenu GUI is currently disabled upstream.

enoop commented on 2014-07-09 23:18

Can this package be built with dbusmenu support? I'm looking to get the appmenu support back.

desaparecido commented on 2014-06-28 23:43

hi, only to report this, building all KF5 -git I have this error almost at the end :(

-- Set runtime path of "/home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/lib/libkdeinit5_kglobalaccel5.so" to "/opt/kf5/lib"
-- Installing: /home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/bin/kglobalaccel5
-- Set runtime path of "/home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/bin/kglobalaccel5" to "/opt/kf5/lib"
-- Installing: /home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/share/kservices5/kglobalaccel5.desktop
-- Installing: /home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/share/dbus-1/services/org.kde.kglobalaccel.service
-- Installing: /home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/lib/qt/plugins/kded_soliduiserver.so
-- Set runtime path of "/home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/lib/qt/plugins/kded_soliduiserver.so" to "/opt/kf5/lib"
-- Installing: /home/luis/builds/kf5-git/plasma-workspace-git/pkg/plasma-workspace-git/opt/kf5/share/kservices5/kded/soliduiserver.desktop
sed: no input files
==> ERROR: A failure occurred in package().
Aborting...

arojas commented on 2014-06-27 21:37

@AnAkkk actually the "fix" (setting LD_LIBRARY_PATH) breaks systemsettings, so I have reverted it. The errors don't seem to cause any issues here.

arojas commented on 2014-06-27 20:33

@AnAkkk fixed, thanks. No need to recompile, just overwrite 10-kf5

AnAkkk commented on 2014-06-27 20:00

I keep getting these errors in .xsession-errors:
Could not open kcminit_startup using a library: Cannot load library /usr/lib/libkdeinit5_kcminit_startup: (/usr/lib/libkdeinit5_kcminit_startup.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)
Could not open ksmserver using a library: Cannot load library /usr/lib/libkdeinit5_ksmserver: (/usr/lib/libkdeinit5_ksmserver.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)

They don't stop plasma from working, but I guess some stuff might be broken.
It's looking for these files in /usr/lib, but they are in /opt/kf5/lib, so I guess something is wrong.

vizor commented on 2014-06-01 11:34

Hello guys,

Do you know how can I make system tray show application icons for applications written in qt5 (like sype or psi or clementine)? As far as I know I need a patched QT4 for this.

Regards

sl1pkn07 commented on 2014-04-26 16:42

please add

export XDG_DATA_DIRS="/opt/kf5/share:$XDG_DATA_DIRS"

greetings

ant32 commented on 2014-04-02 20:34

CMake Error at /opt/kf5/lib/cmake/KF5/KF5Config.cmake:28 (find_package):
Could not find a package configuration file provided by "KF5IdleTime" with
any of the following names:

arojas commented on 2014-04-02 19:04

Warning: This uses now the regular configuration paths .config and .local by default instead of .config5 and .local5.The shell is now more or less usable, and using separate config paths breaks many applications.

If someone wants to test it without touching the configuration folders they should really be logging in as a different user anyway.

arojas commented on 2014-04-02 19:03

Warning: This uses now the regular configuration paths .config and .local by default instead of .config5 and .local5.The shell is now more or less usable, and using separate config paths breaks many applications.

If someone wants to test it without touching the configuration folders they should really be logging in as a different user.

sl1pkn07 commented on 2014-03-31 20:50

this package use bad initial pkgver:

aur/plasma-workspace-git r6.9a17af5-1 -> r58056.75540f2-1

greetings

sl1pkn07 commented on 2014-03-31 07:26

CMake Error at /opt/kf5/lib/cmake/KF5/KF5Config.cmake:28 (find_package):
Could not find a package configuration file provided by "KF5SysGuard" with
any of the following names:

KF5SysGuardConfig.cmake
kf5sysguard-config.cmake


need ksysguard first