Package Details: plasma5-applets-kde-arch-update-notifier-git 7.2.1.r0.ge011f5b-1

Git Clone URL: https://aur.archlinux.org/plasma5-applets-kde-arch-update-notifier-git.git (read-only, click to copy)
Package Base: plasma5-applets-kde-arch-update-notifier-git
Description: A KDE plasmoid for your system tray notifying you of available updates with AUR Support
Upstream URL: https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid
Keywords: kde notify plasmoid Update
Licenses: GPL
Submitter: inkdpanda
Maintainer: inkdpanda
Last Packager: inkdpanda
Votes: 20
Popularity: 0.000037
First Submitted: 2017-06-17 00:24 (UTC)
Last Updated: 2018-11-13 00:14 (UTC)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2022-06-03 20:50 (UTC)

The original code is not developed since 2018.

Here is an up-to-date fork from 2022, with some fixes and improvements:

https://github.com/hikmet517/kde-arch-update-plasmoid.git

renatolond commented on 2019-02-14 08:59 (UTC)

I've also had to install qt5-xmlpatterns for it to work. I think it should be a dependency.

Nek commented on 2018-12-31 02:31 (UTC)

I've had to install qt5-xmlpatterns for this to work, maybe you should list it in the PKGBUILD?

breitj commented on 2018-08-15 09:45 (UTC)

Hi, I think 'plasma-framework' should be added as a (make) dependency. Without it the package fails to build on my system.

nomis6432 commented on 2018-05-29 19:50 (UTC)

/usr/bin/checkupdates has been moved to the pacman-contrib package. this package should be added to the dependencies but in the meantime you can just manually download it.

ranger commented on 2018-03-17 18:27 (UTC)

You can move yakuake to optdepends. I build it without and works just fine. No need to install it if not use it

egrupled commented on 2018-03-04 12:22 (UTC)

Can you add pkgver() section to PKGBUILD: https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function

This way you won't have to manually bump package version after every update and it will be consistent with other -git packages in AUR.

inkdpanda commented on 2018-01-03 15:13 (UTC)

@egrupled

Thank you for the tips, it's updated

egrupled commented on 2018-01-03 10:18 (UTC) (edited on 2018-01-03 10:18 (UTC) by egrupled)

Please change: -DLIB_INSTALL_DIR=lib to -DKDE_INSTALL_LIBDIR=lib

As suggested by:

CMake Deprecation Warning at /usr/share/ECM/kde-modules/KDEInstallDirs.cmake:338 (message): LIB_INSTALL_DIR is deprecated, use KDE_INSTALL_LIBDIR instead.

And arch=('any') to arch=('x86_64') as suggested by namcap:

plasma5-applets-kde-arch-update-notifier-git E: ELF file ('usr/lib/qt/qml/org/kde/private/archUpdate/libplasmoidplugin.so') found in an 'any' package