Package Details: plasma5-applets-plasma-pstate 2.0.0-1

Git Clone URL: https://aur.archlinux.org/plasma5-applets-plasma-pstate.git (read-only, click to copy)
Package Base: plasma5-applets-plasma-pstate
Description: Intel P-state and CPUFreq Manager Widget
Upstream URL: https://github.com/frankenfruity/plasma-pstate
Licenses: GPL2
Submitter: mareex
Maintainer: a.kudelin (franken_fruity)
Last Packager: franken_fruity
Votes: 25
Popularity: 0.92
First Submitted: 2018-12-31 13:27 (UTC)
Last Updated: 2021-10-21 15:21 (UTC)

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

guiodic commented on 2022-05-11 09:24 (UTC)

The dropdown menues don't work (governor, thermal mode) so I'm unable to change them.

Operating System: Manjaro Linux KDE Plasma Version: 5.24.4 KDE Frameworks Version: 5.93.0 Qt Version: 5.15.3 Kernel Version: 5.17.5-1-tt (64-bit) Graphics Platform: X11 Processors: 8 × 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz Memory: 15.4 GiB of RAM Graphics Processor: Mesa Intel® Xe Graphics

commented on 2021-11-09 11:25 (UTC)

Hi @franken_fruity @a.kudelin Can't find issues tab here (https://github.com/frankenfruity/plasma-pstate) so reporting here.

Some sensors not working (CPU Load, CPU Freq, Temperature, Fan rpm). Actually only two sensors are working: Intel GPU Freq and Battery Percentage.

I'm using dell xps 13. Plasma 5.23.2 Thermal Management is working too.

Anyway, thanks for great fork!

lm_sensors is installed and working fine btw.

╰─$ sensors
ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:          20.00 V  (min =  +5.00 V, max = +20.00 V)
curr1:         2.25 A  (max =  +2.25 A)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +44.0°C  

BAT0-acpi-0
Adapter: ACPI interface
in0:           8.29 V  
curr1:       1000.00 uA 

ucsi_source_psy_USBC000:002-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

dell_smm-virtual-0
Adapter: Virtual device
fan1:        4720 RPM
fan2:        4378 RPM

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +49.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +49.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +49.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +47.0°C  (high = +100.0°C, crit = +100.0°C)

nvme-pci-5700
Adapter: PCI adapter
Composite:    +44.9°C  (low  = -20.1°C, high = +81.8°C)
                       (crit = +83.8°C)
Sensor 1:     +44.9°C  (low  = -273.1°C, high = +65261.8°C)

a.kudelin commented on 2021-10-21 12:44 (UTC)

Hi @franken_fruity

I've added you as a co-maintainer. Please commit your changes in PKGBUILD.

franken_fruity commented on 2021-10-20 20:31 (UTC) (edited on 2021-10-20 20:31 (UTC) by franken_fruity)

I've picked up development of this since it's not being maintained by the original author anymore. I've made many changes and improvements. Maintainers, could you consider updating this package to my fork?

The forked source is here:
https://github.com/frankenfruity/plasma-pstate

An updated PKGBUILD is here:
https://github.com/frankenfruity/plasma5-applets-plasma-pstate

brianmsm commented on 2020-11-11 03:42 (UTC)

The user xykrr did a pull request for fix the problem in plasma, that is really simply to implement it: https://github.com/jsalatas/plasma-pstate/pull/64 Unfortunately, jsalatas haven't aproved this change yet, and xykrr didn't the change in his repository. I fork the repository and implemented the change of xykrr in https://github.com/brianmsm/plasma-pstate

All works good here.

a.kudelin commented on 2020-11-08 16:35 (UTC)

@gps, unfortunately you're right, the extension can break plasma to the state of "black screen with mouse pointer". As far as the maintainer of the project dropped the support the only recommendation is to deinstall the package and search for a replacement.

gps commented on 2020-11-05 17:57 (UTC)

this widget stopped being maintained by the author and since October 2020 recent KDE updates something is broken and this widget along with extended calendar widget often tends to be broken and not working breaking main panel, both default KDE panel or Latte panel/dock