Package Details: plasma5-runners-nordvpn 2.1.1-1

Git Clone URL: https://aur.archlinux.org/plasma5-runners-nordvpn.git (read-only, click to copy)
Package Base: plasma5-runners-nordvpn
Description: Nordvpn plasma runner
Upstream URL: https://github.com/alex1701c/NordVPNKrunner
Keywords: kde krunner nordvpn plasma vpn
Licenses: MIT
Submitter: asermax
Maintainer: asermax
Last Packager: asermax
Votes: 2
Popularity: 0.000003
First Submitted: 2020-11-24 00:51 (UTC)
Last Updated: 2022-05-09 00:55 (UTC)

Latest Comments

SolarAquarion commented on 2022-01-22 23:13 (UTC)

/build/plasma5-runners-nordvpn/src/NordVPNKrunner-2.1.0/src/config/nordvpn_config.cpp:14:10: fatal error: kcmutils_version.h: No such file or directory 14 | #include "kcmutils_version.h"

kcmutils is a makedepend

asermax commented on 2022-01-21 03:24 (UTC)

Hey! Sorry for the delay on my answer! I think I resolved the issues on the package, for some reason I was under the impression that fakeroot did more than it actually does; hence I only copied over the installation script bits that looked good from the original repo and called it a day. I changed it now to properly use the make install command and included the icon into the package's source.

In any case, thanks for the feedback!

PS: anyone that installed this package before this fix will probably have conflicts installed the new version; deleting the old files manually should address the issue, sorry about that!

SolarAquarion commented on 2022-01-10 17:28 (UTC) (edited on 2022-01-10 17:30 (UTC) by SolarAquarion)

"https://s1.nordcdn.com/nordvpn/media/1.170.0/images/global/favicon/apple-touch-icon-57x57.png"

should be part of the source. and it should be installed to $pkgdir

DESTDIR=$pkgdir make install

SolarAquarion commented on 2022-01-10 17:26 (UTC)

kcmutils are also a necessity. You shouldn't be using sudo in a pkgbuild. It's a no-no

asermax commented on 2022-01-10 00:40 (UTC)

Hi there! Made some changes to get this building again. The main problem I was having, though, is that currently the krunner package is on version 5.90, while other KDE packages are on version 5.89; I had to downgrade krunner to get the NordVPN runner to build correctly (once built you can upgrade safely again).

SolarAquarion commented on 2022-01-09 23:04 (UTC)

plasma-frameworks are necessary

sl1pkn07 commented on 2021-12-16 22:50 (UTC)

package broken. install nothing