Package Details: platformio 3.6.3-1

Git Clone URL: https://aur.archlinux.org/platformio.git (read-only)
Package Base: platformio
Description: A cross-platform code builder and library manager
Upstream URL: https://github.com/platformio/platformio-core/
Keywords: arduino builder platformio
Licenses: Apache
Conflicts: platformio-git
Submitter: zer0chain
Maintainer: zer0chain (GPereira)
Last Packager: GPereira
Votes: 38
Popularity: 0.938276
First Submitted: 2016-02-11 15:01
Last Updated: 2019-01-10 17:41

Latest Comments

1 2 3 Next › Last »

jd72 commented on 2019-01-13 21:22

What should I do with this?

================================= . . . Reading local package database... :: error: Failed to remove installed dependencies, packages inconsistency: python2-click Do you want to proceed? [Y/n] :: Removing already installed dependencies for platformio: checking dependencies... error: failed to prepare transaction (could not satisfy dependencies) :: python2-incremental: removing python2-click-5.1 breaks dependency 'python2-click' Command 'sudo pacman --color=always --remove python2-semantic-version python2-bottle python2-click-5.1 python2-arrow python2-pyserial' failed to execute. . . . =================================

GPereira commented on 2019-01-10 17:43

Fixed and updated!

ThreadRipper commented on 2018-02-15 01:24

Still failing- error: target not found: python2-click-5.1

ginkel commented on 2017-11-17 22:15

Unfortunately, the installation currently fails due to a broken python-click-5.1 dependency. Any ideas?

zer0chain commented on 2017-08-04 07:19

Thanks @MrHaroldA

I can't (or I don't know how) set several rules for the deps version so I put a >=3.4 to be sure it's not using 3.3.

MrHaroldA commented on 2017-08-04 06:56

The latest version does not work with community/python2-pyserial 3.4-1 installed as the build specifically asks for < 3.3, while 3.4 should be ok.

https://www.archlinux.org/packages/community/any/python2-pyserial/
https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc

Please remove the < 3.3 restriction, or make it a specific one like upstream does: "pyserial>=3,<4,!=3.3".

z3ntu commented on 2017-07-13 11:43

Doesn't work with python2-pyserial 3.3. See https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc . Downgrading python2-pyserial worked.

zer0chain commented on 2017-03-30 06:28

Done guys ;)

Jake commented on 2017-03-29 22:14

Yes, i can also confirm that arrow is required.

@zer0chain
Could you add 'python2-arrow' to the dependencies?
Or add me as co-maintainer and i can push the changes.
Thanks

frazar0 commented on 2017-03-28 07:27

Is it possible that "python-arrow" is a required dependency?
After updating, I get

$ platformio update

Traceback (most recent call last):
File "/usr/bin/platformio", line 6, in <module>
from pkg_resources import load_entry_point
... MORE TRACEBACK LINES ...
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'arrow<1' distribution was not found and is required by platformio

Installing "python-arrow" fixed this.

Can be confirmed by looking at https://github.com/platformio/platformio-core/blob/release/v3.3.0/setup.py

install_requires = [
"arrow<1",
"bottle<0.13",
... MORE DEPENDENCIES ...
]