Package Details: plv8-bin 1.4.10-3

Git Clone URL: https://aur.archlinux.org/plv8-bin.git (read-only)
Package Base: plv8-bin
Description: plv8js is a procedural language add-on for PostgreSQL
Upstream URL: https://code.google.com/p/plv8js/
Licenses: BSD New
Conflicts: plv8-9.4-bin, plv8js-git
Provides: plv8
Submitter: kageurufu
Maintainer: kageurufu
Last Packager: kageurufu
Votes: 0
Popularity: 0.000000
First Submitted: 2016-03-31 16:12
Last Updated: 2017-12-14 18:04

Latest Comments

kageurufu commented on 2017-12-14 18:05

This is still plv8 1.4.10, because this tracks http://apt.postgresql.org/pub/repos/apt/pool/main/p/plv8/ which has not released a 2.x plv8 package. If you need plv8 2.0, I recommend building aur/plv8 yourself.

ArchNoob commented on 2017-03-31 09:22

Hi,

I'm using postgres version 9.6 and when installing this package I get message saying:
" :: no results found for postgresql<9.6 (dependency tree: plv8-bin postgresql)"

Checked the PKBUILD seems it's only limited to Postgres 9.5.

Can you please update, and maybe even use pvl8 version 2.

Thanks.

alpertuna commented on 2016-09-26 23:14

I'm sorry for late reply.
- Output of ldd;
linux-vdso.so.1 (0x00007fffe62b2000)
libv8.so.3.14.5 => /usr/lib/libv8.so.3.14.5 (0x00007f8877184000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f8876dfc000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f8876be5000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f8876847000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f8876543000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f8876326000)
/usr/lib64/ld-linux-x86-64.so.2 (0x000056332c225000)

- And libv8 version is 3.14.5 as above output.

- About logs, I coulnd't find any fail log, it may prints that error to just stdout. After trying to create function with plv8 lang, it failed with message as I post before. Then, I checked journalctl -u postgresql and systemctl status postgresql, and output of them is;
Sep 27 01:50:04 shadow systemd[1]: Starting PostgreSQL database server...
Sep 27 01:50:05 shadow postgres[1961]: LOG: database system was shut down at 2016-09-24 16:23:5
Sep 27 01:50:05 shadow postgres[1961]: LOG: MultiXact member wraparound protections are now ena
Sep 27 01:50:05 shadow postgres[1961]: LOG: database system is ready to accept connections
Sep 27 01:50:05 shadow postgres[1961]: LOG: autovacuum launcher started
Sep 27 01:50:06 shadow systemd[1]: Started PostgreSQL database server.

kageurufu commented on 2016-09-23 23:56

Can you provide your postgres log showing the crash, output of ldd /usr/lib/postgresql/plv8.so, and then output of whichever version of libv8 it is picking up?

alpertuna commented on 2016-09-23 20:30

Hi, I use postgresql 9.5.4 and I installed `v8-3.14` and this `plv8-bin`.
However, after `CREATE EXTENSION plv8`, when I try to create function using plv8 language, postgresql server crushes with this message;

server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.
The connection to the server was lost. Attempting reset: Failed.

Dependencies may be out of date, or library versions are not suitable for postgre 9.5.4.