Package Details: plymouth-legacy 0.8.8-4

Git Clone URL: https://aur.archlinux.org/plymouth-legacy.git (read-only)
Package Base: plymouth-legacy
Description: A graphical boot splash screen with kernel mode-setting support. Legacy version since v9 is currently broken.
Upstream URL: http://www.freedesktop.org/wiki/Software/Plymouth/
Licenses: GPL
Conflicts: plymouth, plymouth-git
Provides: plymouth
Submitter: flamusdiu
Maintainer: flamusdiu
Last Packager: flamusdiu
Votes: 10
Popularity: 0.002648
First Submitted: 2014-09-06 17:51
Last Updated: 2015-06-14 02:18

Required by (26)

Sources (14)

Latest Comments

arkeiro commented on 2015-01-19 19:10

flamusdiu,

Thank you very much ;)

flamusdiu commented on 2015-01-05 21:53

Okay, try it now. Should be working.

arkeiro commented on 2015-01-05 20:17

Same problem here. Please, fix this.

WorMzy commented on 2015-01-05 11:21

Does not install with pacman 4.2 due to the systemd files being installed to /lib, rather than /usr/lib.

https://bbs.archlinux.org/viewtopic.php?id=191857

mumen1994 commented on 2015-01-05 09:25

Package builds fine but wont install:
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) plymouth-legacy-0.8.8-2

Total Installed Size: 1.45 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [#########################################] 100%
(1/1) checking package integrity [#########################################] 100%
(1/1) loading package files [#########################################] 100%
(1/1) checking for file conflicts [###################################kcm######] 100%
error: failed to commit transaction (conflicting files)
plymouth-legacy: /lib exists in filesystem
Errors occurred, no packages were upgraded.

flamusdiu commented on 2014-10-27 23:45

I don't think so. spinfinity (I thought) was the default so it should always work.

dubtastisch commented on 2014-10-26 06:19

@flamusdiu

I'm using spinfinity with no problems...maybe I just broke it so bad that I inadvertently fixed it lol

flamusdiu commented on 2014-10-25 13:19

@dubtastisch:

If you use a non-default theme, does it work? Part of the reason for the plymouth hook is so you can theme it.

dubtastisch commented on 2014-10-25 06:35

NyQuil's fix alone didn't work for me, and I use KDM. I don't know why what I did fixed it, but it did. In addition to NyQuil's fix, I:

Commented out all lines in /usr/lib/systemd/system/plymouth-quit-wait.service
Removed "plymouth" hook and ran mkinitcpio
Left "splash" in my rEFInd kernel parameters

NyQuil commented on 2014-10-13 07:24

@flamusdiu: I'm using KDM.

flamusdiu commented on 2014-10-11 21:01

@NyQuil: Do you use a login manager such as SLiM, gdm, or something else?

I just noticed that moving from SLiM to SDDM seems to have fixed the issue for me without modifying any files but I'll need to do another test on my laptop to be sure.

flamusdiu commented on 2014-10-09 19:31

@NyQuil: I'll have to try this later. Thanks

NyQuil commented on 2014-10-09 18:16

I had the same issue with Xorg and KDM (Xserver timed out and KDM didn't start), so I changed line 7 in /usr/lib/systemd/system/plymouth-quit.service

from
ExecStart=-/usr/bin/plymouth quit --retain-splash
to
ExecStart=-/usr/bin/plymouth quit

This fixed the issue for me on all my machines...

Gabe commented on 2014-09-25 17:43

Still broken for GDM users. plymouth-quit-wait.service just hangs, prevents Xorg and GDM startup.

flamusdiu commented on 2014-09-09 02:56

@martkzz: when I get back on my laptop -- I'll see what's different and go from there -- might be an easy fix.

flamusdiu commented on 2014-09-09 02:42

@martkzz: that's what I've heard but I don't use GDM. =(

I'll take a look.

markzz commented on 2014-09-09 02:13

Something seems to be broken in this package for users of GDM.
https://bbs.archlinux.org/viewtopic.php?id=186752

flamusdiu commented on 2014-09-07 16:31

BTW: I use SLiM so I haven't noticed the issue. =\

flamusdiu commented on 2014-09-07 16:30

Yeah, just noticed that.

Note: Fixed the source url. =)

dangerginger commented on 2014-09-07 16:07

@flamusdiu, It looks like that patch is incorporated into this version. There is no [Install] section in plymouth-quit.service. Thanks, though.

flamusdiu commented on 2014-09-07 15:26

@jkav77: have you tried this: http://cgit.freedesktop.org/plymouth/commit/systemd-units/plymouth-quit.service.in?id=2c65fc7c2295cd07342bea08761b09c169594d4f

flamusdiu commented on 2014-09-07 15:20

Oops ... my fault. I added the wrong source URL. =P @Jkav77 got it.

I'll fix it when I can get back on my Linux box (kinda broken it atm).

pintergreg commented on 2014-09-07 11:49

source url is broken, 404 for me, but http://pkgs.fedoraproject.org/repo/pkgs/plymouth/plymouth-0.8.8.tar.bz2/38f5e613e5ab17806b950cee2d0d0d4e/plymouth-0.8.8.tar.bz2 works.

dangerginger commented on 2014-09-06 19:47

I installed this successfuly and it works, but I can't get my login manager (GDM) to appear due to an error with plymouth-quit-wait.service. I couldn't google up any solutions, just lots of problems. If anyone gets this working, let me know.

dangerginger commented on 2014-09-06 18:03

The line to get the source in the PKGBUILD should read as below. Not I added an '_' to pkgname in the url.

source=("http://www.freedesktop.org/software/${_pkgname}/releases/${_pkgname}-${pkgver}.tar.bz2"

dangerginger commented on 2014-09-06 18:00

I am getting a 404 on the source code.

flamusdiu commented on 2014-09-06 17:53

This is exactly like https://aur.archlinux.org/packages/plymouth/ except this uses the 0.8.8 version from upstream and the update script is patched properly.