Package Details: pnmixer 0.7.2-1

Git Clone URL: https://aur.archlinux.org/pnmixer.git (read-only)
Package Base: pnmixer
Description: GTK volume mixer applet that runs in the system tray.
Upstream URL: https://github.com/nicklan/pnmixer
Licenses: GPL
Submitter: nickl
Maintainer: bidulock
Last Packager: bidulock
Votes: 134
Popularity: 0.188451
First Submitted: 2011-05-10 13:10
Last Updated: 2017-07-03 22:48

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

ant commented on 2013-02-15 23:52

qvx, thanks for this. nickl, please update the PKGBUILD to include qvx's patch as follows:

# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
# Maintainer: Nick Lanham <nick@nick>
pkgname=pnmixer
pkgver=0.5.1
pkgrel=2
pkgdesc="PNMixer is a GTK volume mixer applet that runs in the system tray. \
It is lightweight, works with both pulseaudio and alsa, supports mouse wheel \
volume adjustment, works with tint2, and can run outside of gnome. \
PNMixer provides many configuration options including which icon theme \
to use for display, middle click actions and more.\
PNMixer is a fork of OBMixer.
"
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/nicklan/pnmixer"
groups=('pnmixer')
depends=('gtk2' 'alsa-lib')

source=(https://github.com/downloads/nicklan/pnmixer/pnmixer-${pkgver}.tar.gz pnmixer-0.5.1-configure.in.patch)
md5sums=('2288af95ab280721b39b7c33601d5dd4' '08ef9539f2dec3ad1fcc8d5b34797b6a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"

patch -Np0 -i ../pnmixer-0.5.1-configure.in.patch
./autogen.sh || return 1
./configure --prefix=/usr || return 1
make || return 1
make DESTDIR="$pkgdir" install || return 1
}

qvx commented on 2013-02-15 16:35

Try this patch. I have just compiled pnmixer.
http://pastebin.com/ZECA3rn9

Hamish commented on 2013-02-14 19:27

Same issue as Boohbah, jwhipp, gastong34, and Nothing4You.

Nothing4You commented on 2013-02-13 02:12

Same error as Boohbah, jwhipp and gastong34.

jwhipp commented on 2013-02-11 15:58

Volti has the set icon theme feature that I need but I still would love to see this working. The issue is in the pnmixer source as the aur git package and direct source all do the same thing.

ant commented on 2013-02-10 23:11

I am using volumeicon, since I did not manage to make pnmixer to work too. But volumeicon can only open the mixer in a terminal. What we really miss is a GUI version of alsamixer. I can use the terminal very well, but it may be confusing for a novice.

jsteel commented on 2013-02-10 23:03

volumeicon in [community] is good for an openbox/tint2 setup.

Anonymous comment on 2013-02-10 22:33

Same problem as jwhipp and Boohbah, this is the best applet for openbox/tint2 and I can't get it to work :s

jwhipp commented on 2013-01-30 06:49

Not sure why this is marked out of date. The latest release is 0.5.1.

jwhipp commented on 2013-01-27 22:02

Same problem as Boohbah:

./configure: line 1867: syntax error near unexpected token `pnmixer,'
./configure: line 1867: `AM_INIT_AUTOMAKE(pnmixer, 0.5.1)'
==> ERROR: A failure occurred in build().
Aborting...