Package Details: poco 1.7.5-1

Git Clone URL: https://aur.archlinux.org/poco.git (read-only)
Package Base: poco
Description: C++ class libraries for network-centric, portable applications, complete edition with debug libraries
Upstream URL: http://www.pocoproject.org/
Licenses: custom:boost
Conflicts: poco-dev
Provides: poco-dev
Replaces: poco-dev
Submitter: wuischke
Maintainer: ido (rew)
Last Packager: rew
Votes: 96
Popularity: 0.429507
First Submitted: 2007-10-28 11:02
Last Updated: 2016-08-29 11:32

Latest Comments

ido commented on 2016-07-17 19:02

Thanks @rew. I added you as a comaintainer. If you want to take over this package, I can disown it and you'll become the primary maintainer, just let me know.

rew commented on 2016-05-02 20:29

I can. I've had a pull request opened (https://github.com/ido/packages-archlinux/pull/74) to update this to 1.7.0 (now 1.7.3) for a while.

ido commented on 2016-03-31 18:28

Does anyone want to take on co-maintainership to help improve this package and update it?

v01d commented on 2016-03-08 14:54

hi, current PKGBUILD builds debug versions of the package also, which is time consuming and does not make much sense since debug symbols are stripped anyways by makepkg. It would be nice if debug building could be avoided to speed up compilation.

There's a CMakeLists file which I think allows this, but I'm not sure.

ido commented on 2015-09-04 16:02

Thanks, can you submit a pull request?

skydrome commented on 2015-08-08 04:04

1.6.1 is released

eomarjee commented on 2015-02-05 18:43

I had to add POCO_ODBC_LIB=/usr/lib to make and make install for building this package.

ido commented on 2015-01-26 20:28

NOTE: To request changes to this package, please submit a pull request
to the GitHub repository at https://github.com/ido/packages-archlinux
Otherwise, open a GitHub issue. Thank you! -Ido

ido commented on 2015-01-26 18:56

(Until tomorrow, poco-dev is an alternative.)

ido commented on 2015-01-26 18:55

Adopting this package, will update it later this week & integrate it with other packages I maintain.

All comments