Package Details: podman-compose-git 1:1.0.7.r161.6103df7-1

Git Clone URL: https://aur.archlinux.org/podman-compose-git.git (read-only, click to copy)
Package Base: podman-compose-git
Description: A script to run docker-compose.yml using podman
Upstream URL: https://github.com/containers/podman-compose
Licenses: GPL2
Conflicts: podman-compose
Provides: podman-compose
Submitter: nightuser
Maintainer: nightuser
Last Packager: nightuser
Votes: 3
Popularity: 0.000093
First Submitted: 2020-03-12 22:13 (UTC)
Last Updated: 2024-04-04 17:16 (UTC)

Dependencies (6)

Required by (1)

Sources (1)

Latest Comments

xiota commented on 2023-12-20 09:09 (UTC)

pkgver() is generating strings like 1:.r56.bce40c2. Should switch to following:

pkgver() {
  cd "${pkgname%-git}"
  git describe --long --tags | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}

FallenWarrior2k commented on 2022-08-08 15:20 (UTC)

pkgver has started failing again because upstream now uses a double-quoted string instead of a single-quoted one to delimit the version string in the file (link), causing the grep regex to fail to match.

nightuser commented on 2022-01-02 14:55 (UTC)

@FallenWarrior2k: The dotenv dependency was missing indeed. As for the epoch bump, I don't think this package has a lot of users, but I still increased it.

Actually, I'm more surprised that makepkg changes the version number even if the pkgver function fails (is it because of the subshells?)

FallenWarrior2k commented on 2022-01-01 19:25 (UTC)

On my machine, pkgver returns bogus because the Python dotenv module is missing.

==> Starting pkgver()...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/simon/.cache/yay/podman-compose-git/src/podman-compose/podman_compose.py", line 34, in <module>
    from dotenv import dotenv_values
ModuleNotFoundError: No module named 'dotenv'
==> Updated version: podman-compose-git .r17.0bd493f-1

This might actually require an epoch bump to properly fix because when I installed python-dotenv and rebuilt the package, pacman at first complained: warning: downgrading package podman-compose-git (.r17.0bd493f-1 => 1.0.3.r17.0bd493f-1).

harmathy commented on 2020-11-30 16:41 (UTC)

As this is an VCS package, this isn't out-of-date!

See https://wiki.archlinux.org/index.php/Arch_User_Repository#Flagging_packages_out-of-date