Package Details: pology-svn 1495839-1

Git Clone URL: https://aur.archlinux.org/pology-svn.git (read-only)
Package Base: pology-svn
Description: A framework for custom processing of PO files.
Upstream URL: http://techbase.kde.org/Localization/Tools/Pology
Licenses: GPL3
Provides: pology
Submitter: Gilrain
Maintainer: Gilrain
Last Packager: Gilrain
Votes: 6
Popularity: 0.000000
First Submitted: 2009-11-19 16:33
Last Updated: 2017-08-17 09:52

Dependencies (18)

Required by (1)

Sources (1)

Latest Comments

Gilrain commented on 2017-08-17 09:57

Thanks for reporting it.
Unfortunately, there are two more upstream bugs during compilation:

-- Could NOT find DocbookXSL: Found unsuitable version "snapshot", but required is at least "1.75.2" (found /usr/share/xml/docbook/xsl-stylesheets-1.79.2)
-- Could NOT find Pygments: Found unsuitable version "", but required is at least "1.6" (found /usr/lib/python2.7/site-packages/pygments)

wget commented on 2017-08-13 19:36

You need to add community/python2-pyenchant to the depends array, otherwise it does not build.

Optional dependencies have to be updated as well.

Gilrain commented on 2012-03-23 09:57

When you upgrade, please be aware that pology-svn now resides in /usr instead of /opt.

Gilrain commented on 2011-02-05 23:31

Fixed, thank you.

unhammer commented on 2011-02-05 16:35

Shouldn't python-pyenchant be python2-pyenchant ?

Gilrain commented on 2010-10-19 12:21

To keep your installation updated you could use this simple script:

#!/bin/sh
# /etc/cron.weekly/pology: updates pology using svn

svn up --non-interactive --quiet /opt/pology
# python2 fix
sed -i -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' $(find /opt/pology -name '*.py')

Gilrain commented on 2010-08-18 16:39

To keep your installation updated you could use this simple script:

#!/bin/sh
# /etc/cron.weekly/pology: updates pology using svn
svn up --non-interactive --quiet /opt/pology