Package Details: polybar 3.3.1-2

Git Clone URL: https://aur.archlinux.org/polybar.git (read-only)
Package Base: polybar
Description: A fast and easy-to-use status bar
Upstream URL: https://github.com/polybar/polybar
Keywords: bar bspwm i3 lemonbar lemonbuddy polybar
Licenses: MIT
Conflicts: polybar-git
Submitter: jaagr
Maintainer: jaagr (NBonaparte, patrick96)
Last Packager: patrick96
Votes: 191
Popularity: 13.067927
First Submitted: 2016-11-19 05:09
Last Updated: 2019-06-23 19:24

Dependencies (21)

Required by (2)

Sources (1)

Pinned Comments

TheGreatAndyChow commented on 2019-04-23 03:46

For problems with conda, simply "conda deactivate", it will install. No need to purge path or remove anaconda.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

kvnbai commented on 2019-05-01 04:30

@patrick96

Executing the command gives me this:


Fatal Python error: initfsencoding: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding



Current thread 0x00007f2ec0423680 (most recent call first):
Aborted (core dumped)

I tried reinstalling arch instead. The GNU tools or packages related to python might be corrupted.

patrick96 commented on 2019-04-30 12:07

@kvnbai That's strange, since you have xcb-proto installed, the error should not occur. In the case of arch python3 -c "import re,xcbgen;print(re.compile('/xcbgen/__init__.py.*').sub('',xcbgen.__file__))" should print /usr/lib/python3.7/site-packages, could you try if this works, if it does, the problem lies elsewhere.

kvnbai commented on 2019-04-30 09:30

Build currently fails (tried on VM, tested on freshly installed arch & manjaro), the same error "The required python module is missing: xcbgen" pops even conda was not installed (I'm not familiar with anaconda but I'm pretty sure I didn't install such package.), See the screenshot: https://i.imgur.com/YTUsOwe.png

patrick96 commented on 2019-04-25 06:11

@TheGreatAndyChow thanks a lot! I didn't know about this command, I added it to the wiki.

TheGreatAndyChow commented on 2019-04-23 03:46

For problems with conda, simply "conda deactivate", it will install. No need to purge path or remove anaconda.

patrick96 commented on 2019-03-11 08:54

@nrbr Alternatively you can purge both PATH and PKG_CONFIG_PATH of any anaconda paths temporarily. https://github.com/jaagr/polybar/wiki/Known-Issues#building-with-anaconda-installed

nrbr commented on 2019-03-07 03:44

If someone has "The required python module is missing: xcbgen" -> https://github.com/jaagr/polybar/issues/502 Eliminating anaconda works for now. It is not the point but it solves the problem momentarily.

SilverMight commented on 2018-10-25 18:57

Recieved an error complaining about libjsoncpp.so.20 missing. Rebuilding seemed to fix

johnhamelink commented on 2018-07-31 14:52

If anyone is struggling with missing python modules - I found that you have to use the system python (the xcb python module is not something you can pip install, for example). I'm using asdf to manage my pythons, so for me I needed to run "asdf global python system". I hope that helps :)

pmatos commented on 2018-06-12 11:04

@patrick96 Thanks. I managed to get polybar-git to work so I will use that for now.