Package Details: ponysay-git 3.0.2.r2328-1

Git Clone URL: https://aur.archlinux.org/ponysay-git.git (read-only)
Package Base: ponysay-git
Description: Cowsay reimplementation for ponies.
Upstream URL: https://github.com/erkin/ponysay
Licenses: GPL2, FDL
Conflicts: ponysay, ponysay-git
Provides: ponysay
Submitter: gtmanfred
Maintainer: Jristz (maandree)
Last Packager: Jristz
Votes: 7
Popularity: 0.000000
First Submitted: 2012-05-10 19:41
Last Updated: 2016-02-08 03:00

Dependencies (5)

Required by (2)

Sources (1)

Latest Comments

Jristz commented on 2015-06-08 20:29

now with aur4 do you want a co-maintainer :) ?

Jristz commented on 2013-06-24 22:10

http://pastebin.com/1vHjykxu

This is the PKGBUILD that I use and work as spected (3.0.1 is lower than 3.0.1.1 and not have the nasty problem of aur helpers ignoring upstream minor updates 3.0.1.x like this)

fell free to ignore or not

gtmanfred commented on 2013-04-05 21:19

check your email, i am inactive for the month, if you want to supply a working PKGBUILD, I will test it, and add it, (with you as a contributor) otherwise, gimme this month to finish my move and then i will fix it.

I will be back in about 2 more weeks, Thanks for your patience.

gtmanfred commented on 2013-04-05 21:18

check your email, i am inactive for the month, if you want to supply a working PKGBUILD, I will test it, and add it, (with you as a contributor) otherwise, gimme this month to finish my move and then i will fix it

gtmanfred commented on 2013-04-05 21:17

check your email, i am inactive for the month, if you want to supply a working PKGBUILD, I will test it, and add it, (with you as a contributor) otherwise, gimme this month to finish my move and then i will fix it

Jristz commented on 2013-04-05 20:54

licence change too now

Jristz commented on 2013-04-03 20:05

test yourself, new dep and obligatory options

Jristz commented on 2012-10-17 15:08

ok python3.3 rebuild reach extra/community
If any have a problem runing this, please change python for python3 in shebangs and add python3 ./setup.py for the setup script

Jristz commented on 2012-10-10 14:03

ok I warned: python3.3 re-add the shebang to python3
the setup.py need add python3 ad the release of python3.3 in official repo
I warned all users

Jristz commented on 2012-09-15 02:26

ok pdf is intale in /usr/doc and compressed, this is wrong for Arch
arch need the docs not compresed and located in usr/share/doc/appname

--with-pdf-manual=/usr/share/doc/$(_pkgname) --without-pdf-compression is enought for make sure complain about the paths and packaging (probably the = in fisrt option is a mistaken, not sure)

gtmanfred commented on 2012-09-01 16:03

also.... do not use flag Out-of-date unless it is out of date, otherwise use the comments to mention your problems with it being broken

gtmanfred commented on 2012-09-01 15:57

zetaron but you flagged it out of date, again... after I update the pkgbuild and unflagged it

Anonymous comment on 2012-09-01 15:56

becouse yesterday the PKGBUILD was still broken... and since there is no button to flag the PKG as broken I used the out of date flag, to push the situation ;) please don't hate me for that I just couldn't live without my bash ponies anymore ;(

gtmanfred commented on 2012-09-01 01:29

why is this being marked out of date...

gtmanfred commented on 2012-08-29 18:35

I will fix it tonight

Jristz commented on 2012-08-29 18:23

configure was removes in this morning
change the configure to the suggested if have problems go to issue 94

gtmanfred commented on 2012-08-27 15:53

Hibernate, you do not include any dependencies from base-devel

make is in base-devel and it depends on sh, therefore you do not need to specify those

maandree commented on 2012-08-27 15:38

The first paragraph in last comment has been resolved.

maandree commented on 2012-08-27 13:56

DESTDIR has lost effect in 'make install', because it no uses a python script,
and the Makefile has not yet forward that configuration to the python script.
Until such time, --dest-dir must used instead in ./configure

However I would recommend using:

build()
{ ./setup.py --everything --without-pdf-compression build
}

package()
{ ./setup.py --everything --without-pdf-compression --dest-dir="$pkgdir" prebuilt
}

(this also loses three dependences: sh, sed, make)

gtmanfred commented on 2012-08-26 23:57

it has no effect until you do make install, then it uses INSTALLDIR... which uses DESTDIR

maandree commented on 2012-08-26 23:53

Currently DESTDIR is 'make' has no effect, use --dest-dir in './configure' instead.

maandree commented on 2012-08-25 23:47

The line

optdepends=('util-say: tty2colourfultty and ponysay2ttyponysay')

should be changed, 'tty2colourfultty and ponysay2ttyponysay' is not a description of purpose, just a list of used executables.
I suggest changing it to 'util-say>=2: Improved TTY support utilising KMS support, and support for PNG files'

Also specifying 'util-say>=2' rather than 'util-say' is important, as 'util-say<2' uses the cowsay format in the ponysay utils,
while 'util-say>=2' uses the new format in 'ponysay>=2.1'.

gtmanfred commented on 2012-08-25 16:59

python is python3

coreutils fine, specifying both texinfo and gzip is redundent

as is make and bash, make is in base-devel, and requires sh, bash is the provider of sh in the repos

maandree commented on 2012-08-25 16:27

Correct dependency list::

REQUIRED FOR RUNTIME:
python>=3
coreutils

OPTIONAL FOR RUNTIME:
util-say>=2: Improved TTY support utilising KMS support, and support for PNG files

MAKE DEPENDENCIES:
gzip
texinfo
info
make, bash, sed, coreutils (for ponysay 2.5 python>=3 may be used instead with sh and make as optional)
git (if pkgbuild clones git repo)

Jristz commented on 2012-08-24 03:52

er, ponysay is a 'any' package, a python script and 250 ponies (text) only, none to build

Jristz commented on 2012-08-24 03:26

./dependency-test.sh
line 33 and 34, wath say? oh, Missing tty2colourfultty, install util-say [runtime optional], aka optdep, now know this I left the really final decition of adding or not the optdep

gtmanfred commented on 2012-08-24 01:49

the -f option does not require util-say so i am not including that, and I am not going to include every option, if you want pdf, edit the pkgbuild and add --with-pdf

gtmanfred commented on 2012-08-24 01:49

the -f option does not require util-say so i am not including that, and I am not going to include every option, if you want pdf, edit the pkgbuild and add --with-pdf

gtmanfred commented on 2012-08-24 01:43

i don't even know what that says

gtmanfred commented on 2012-08-24 01:40

i don't even know what that says

Jristz commented on 2012-08-24 01:36

I proced to owdate for this reasons: -no more depend on cowsay, now use pyhon3 and coreutils, need specifi a little wath build in configure, many options noy build by default, including pdf, an manpages.es, and finally the -f option can y used in images if util-say is intales aka optdeo util-say

Anonymous comment on 2012-08-21 22:55

makepkg failed to work properly, but under the advice of maandree, on github https://github.com/erkin/ponysay/issues/79 I added ./configure on a line directly above make DESTDIR="$pkgdir/" and it worked fine :)

namzug commented on 2012-07-24 08:36

i'm so glad this exists