Package Details: postgresql-9.4 9.4.7-1

Git Clone URL: https://aur.archlinux.org/postgresql-9.4.git (read-only)
Package Base: postgresql-9.4
Description: A powerful, open source object-relational database system
Upstream URL: http://www.postgresql.org/
Keywords: pg_ctl postgresql postgresql-9.4 psql
Licenses: custom:PostgreSQL
Conflicts: postgresql, postgresql-client, postgresql-libs, postgresql-testing
Provides: postgresql=9.4.7, postgresql-client=9.4.7, postgresql-libs=9.4.7
Submitter: ahungry
Maintainer: ahungry
Last Packager: ahungry
Votes: 4
Popularity: 0.002196
First Submitted: 2016-04-28 04:06
Last Updated: 2016-04-28 04:10

Dependencies (11)

Required by (491)

Sources (7)

Latest Comments

biinari commented on 2017-01-17 05:33

@ahungry, looks like AUR requires just one owner. Happy to take maintainership if you want to disown it. Or if you're happy to go ahead and make the change as gcornut described below and upgrade to 9.4.10 that would be great.

Thanks

ahungry commented on 2017-01-17 02:43

Thanks @biinari that sounds good to me

biinari commented on 2017-01-16 16:14

I'd be happy to update the PKGBUILD and postgresql-check-db-dir to work and upgrade to 9.4.10. Any objections ahungry?

gcornut commented on 2016-06-08 12:40

What I had to do to make postgres work after install:

Create DB:
$ sudo -u postgres initdb -D '/var/lib/postgres/data'

Modify /usr/bin/postgresql-check-db-dir:
...
# PGMAJORVERSION is major version
PGMAJORVERSION=9.4
# PREVMAJORVERSION is the previous major version, e.g., 8.4, for upgrades
PREVMAJORVERSION=9.3
...

Start service:
$ systemctl start postgresql.service