Package Details: postgresql-9.5 9.5.22-3

Git Clone URL: https://aur.archlinux.org/postgresql-9.5.git (read-only, click to copy)
Package Base: postgresql-9.5
Description: Libraries for use with PostgreSQL
Upstream URL: https://www.postgresql.org/
Licenses: custom:PostgreSQL
Conflicts: postgresql
Provides: postgresql
Submitter: qoobaa
Maintainer: qoobaa (vitaliel)
Last Packager: TheGoliath
Votes: 2
Popularity: 0.000000
First Submitted: 2016-11-28 10:57 (UTC)
Last Updated: 2020-05-25 09:48 (UTC)

Required by (322)

Sources (9)

Latest Comments

Malstrond commented on 2020-06-04 15:12 (UTC)

Sorry for the late feedback.

The new service file works, thanks!

Malstrond commented on 2020-05-24 17:09 (UTC)

The problem is still present with the new service file.

Malstrond commented on 2020-05-24 08:31 (UTC) (edited on 2020-05-24 09:07 (UTC) by Malstrond)

Since the changes to the .service file from 9.5.21, my systemd doesn't recognize that postgres has started sucessfully anymore. postgres starts, client applications can use it, but systemd kills it anyway after 120s. I need to set TimeoutSec=infinity for it to work.

systemd[1]: Starting PostgreSQL database server...
postgres[46943]: 2020-05-24 04:00:36 EDT   LOG:  Logausgabe wird an Logsammelprozess umgeleitet
postgres[46943]: 2020-05-24 04:00:36 EDT   TIPP:  Die weitere Logausgabe wird im Verzeichnis »pg_log« erscheinen.
postgresql.service: start operation timed out. Terminating.
Killing process 46945 (postgres) with signal SIGKILL.
Failed with result 'timeout'.
Failed to start PostgreSQL database server.

Might be related to this bug: https://bugs.archlinux.org/task/58544

The upstream documentation for 12 recommends TimeoutSec=0 too: https://www.postgresql.org/docs/current/server-start.html

Although everything related to startup on systemd is missing from the 9.5 documentation. Maybe 9.5 is missing some systemd integration features? This might explain why the same .service file works with version 12 in the offical package.

qoobaa commented on 2020-04-26 06:52 (UTC)

@TheGoliath - you're co-maintainer now

kidsatch commented on 2017-06-01 14:11 (UTC)

to resolve error "error: library 'ssl' is required for OpenSSL" change PKGBUILD --with-openssl \ -> --with-openssl-1.0 \