Package Details: postgresql-9.6 9.6.24-1

Git Clone URL: https://aur.archlinux.org/postgresql-9.6.git (read-only, click to copy)
Package Base: postgresql-9.6
Description: Sophisticated object-relational DBMS
Upstream URL: https://www.postgresql.org/
Licenses: custom:PostgreSQL
Conflicts: postgresql
Provides: postgresql
Submitter: someonerandom
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 5
Popularity: 0.000000
First Submitted: 2017-11-26 10:00 (UTC)
Last Updated: 2021-12-07 20:41 (UTC)

Required by (324)

Sources (9)

Pinned Comments

frealgagu commented on 2020-12-18 07:34 (UTC)

I maintain the latest built package at:

https://github.com/frealgagu/archlinux.postgresql-9.6/releases/

Latest Comments

Rawleenc commented on 2021-12-08 09:54 (UTC)

@frealgagu The issue seems to be resolved with the latest binaries you've uploaded on your github. Thank you so much for maintaining this PostgreSQL version. Feel free to close the related issue on your github.

frealgagu commented on 2021-12-07 18:40 (UTC)

@Rawleenc I've done a fresh install of the package and everything is OK, what are the steps to reproduce it? Currently using libldap 2.6.0-2

Rawleenc commented on 2021-11-19 10:55 (UTC)

With the release of libldap 2.6 on archlinux's core repository (https://archlinux.org/packages/core/x86_64/libldap/), there is an essential file for psql 9.6 that has been removed : libldap_r-2.4.so.2.

So in order for this package to continue to work, libldap package need to be locked on the latest 2.4 version.

I've also tried to create a symlink named libldap_r-2.4.so.2 who target /usr/lib/libldap.so but it doesn't work.

This will be a big issue for all new archlinux's installations who need to run a psql 9.6 server...

frealgagu commented on 2020-12-18 07:34 (UTC)

I maintain the latest built package at:

https://github.com/frealgagu/archlinux.postgresql-9.6/releases/

someonerandom commented on 2019-12-11 06:14 (UTC)

@Raniz: Please make sure your system libs are up to date. I can't reproduce this (tcl-8.6.10-1, glibc-2.30-3).

Raniz commented on 2019-12-11 05:57 (UTC)

Compilation fails with an error about not being able to find -lieee. Disabling TCL works, but might not be desired for everyone.

hschletz commented on 2019-01-30 13:04 (UTC)

Needs rebuild because of new readline version.

ainola commented on 2018-10-12 14:51 (UTC)

Thanks for maintaining this, someonerandom!

Please re-generate the SRCINFO: AUR helpers are grumpy because the version is 9.6.10-2 whereas the AUR lists it as 9.6.10-1 ("Local version of blah is newer than upstream").

someonerandom commented on 2018-08-26 19:11 (UTC)

@jatone: I don't know what you mean. Please post a modified PKGBUILD which fixes the problem.

jatone commented on 2018-08-14 20:21 (UTC) (edited on 2018-08-14 20:24 (UTC) by jatone)

doesn't use system python when building which can cause compiling to fail due to python tooling such as miniconda.

Singularity commented on 2018-06-18 16:59 (UTC)

This package serves as well postgresql-docs