Package Details: postgresql15 15.6-2

Git Clone URL: https://aur.archlinux.org/postgresql15.git (read-only, click to copy)
Package Base: postgresql15
Description: Sophisticated object-relational DBMS
Upstream URL: https://www.postgresql.org/
Licenses: custom:PostgreSQL
Provides: postgresql
Submitter: mrechte
Maintainer: mrechte
Last Packager: mrechte
Votes: 1
Popularity: 0.100108
First Submitted: 2023-12-08 11:01 (UTC)
Last Updated: 2024-02-21 16:17 (UTC)

Required by (341)

Sources (8)

Pinned Comments

mrechte commented on 2023-12-08 11:02 (UTC) (edited on 2023-12-26 14:39 (UTC) by mrechte)

Introduction

This version may cohabit with other major versions, including the official one.

Data directory is /var/lib/postgres/data15

Initialize the database
su - postgres
. /opt/postgresql15/bin/pgenv.sh
initdb -k
Start the service
systemctl start postgresql15
Use the service
. /opt/postgresql15/bin/pgenv.sh
psql -U postgres

Latest Comments

mrechte commented on 2024-02-21 16:18 (UTC)

@hschletz thanks for reporting. I though I had already fixed the issue. This should be OK now.

hschletz commented on 2024-02-19 10:24 (UTC) (edited on 2024-02-19 10:25 (UTC) by hschletz)

As libraries are installed into a non-default path, applications linked against libpq won't find it unless the official postgresql-libs package is installed too. pgenv.sh has a line with LD_LIBRARY_PATH commented out, but that would work only for shells that source the script, but not system services. To enable the library globally, create a file /etc/ld.so.conf.d/postgresql15.conf containing:

/opt/postgresql15/lib

Then run "ldconfig".

xeruf commented on 2024-01-22 16:07 (UTC)

Getting very odd compilation failure despite everything looking successful:

============== shutting down postmaster               ==============
============== removing temporary instance            ==============

=======================
 All 212 tests passed. 
=======================

make[1]: Leaving directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/test/regress'
make -C ./src/backend generated-headers
make[1]: Entering directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend'
make -C catalog distprep generated-header-symlinks
make -C utils distprep generated-header-symlinks
make[2]: Entering directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend/utils'
make[2]: Nothing to be done for 'distprep'.
make[2]: Nothing to be done for 'generated-header-symlinks'.
make[2]: Leaving directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend/utils'
make[2]: Entering directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend/catalog'
make[2]: Nothing to be done for 'distprep'.
make[2]: Nothing to be done for 'generated-header-symlinks'.
make[2]: Leaving directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend/catalog'
make[1]: Leaving directory '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5/src/backend'
rm -rf '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5'/tmp_install
/usr/bin/mkdir -p '/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5'/tmp_install/log
make -C '.' DESTDIR='/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5'/tmp_install install >'/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5'/tmp_install/log/install.log 2>&1
make -j1  checkprep >>'/home/janek/.local/cache/yay/postgresql15/src/postgresql-15.5'/tmp_install/log/install.log 2>&1
make: *** [src/Makefile.global:412: temp-install] Error 2
==> ERROR: A failure occurred in check().
    Aborting...
 -> error making: postgresql15-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
postgresql15-libs - exit status 4
postgresql11-libs - exit status 4
postgresql11 - exit status 4
postgresql15 - exit status 4

kescherAUR commented on 2023-12-26 16:02 (UTC)

@mrechte You should also put perl back into the depends array from optdepends

mrechte commented on 2023-12-26 14:46 (UTC)

Now includes --with-perl. Thanks to @kescherAUR.

kescherAUR commented on 2023-12-21 22:46 (UTC) (edited on 2023-12-26 15:58 (UTC) by kescherAUR)

This package may fail on two tests when uncommenting the --with-perl option with perl installed. Setting LANG=C before make "${1}" in _postgres_check fixes the issue. No idea if LC_ variables also need to be overridden if they are set.

mrechte commented on 2023-12-19 14:12 (UTC)

Thanks for the report. Fixed in 15.5-4.

carsme commented on 2023-12-19 11:13 (UTC)

Experiencing the same issue as @fbrennan, this fails to build.

fbrennan commented on 2023-12-11 07:49 (UTC)

Build fails due to PostgreSQL 15 needing deprecated XML functions.

I needed this patch to build:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- From f6b1cf3d51c8e1549114c3532d70d706adbd35a5 Mon Sep 17 00:00:00 2001
From: Fredrick Brennan <copypaste@kittens.ph>
Date: Mon, 11 Dec 2023 02:47:54 -0500
Subject: [PATCH] require libxml2-2.9

- ---
 PKGBUILD | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD
index a0d7d17..72f2dee 100644
- --- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url='https://www.postgresql.org/'
 arch=('x86_64')
 provides=("postgresql")
 license=('custom:PostgreSQL')
- -makedepends=('krb5' 'libxml2' 'python' 'tcl>=8.6.0' 'openssl>=1.0.0'
+makedepends=('krb5' 'libxml2-2.9' 'python' 'tcl>=8.6.0' 'openssl>=1.0.0'
              'pam' 'zlib' 'icu' 'systemd' 'libldap' 'llvm' 'clang' 'libxslt')
 optdepends=('perl: perl support requires recompile with --with-perl')
 source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
@@ -65,6 +65,10 @@ build() {
   # Fix static libs (will not link if not set)
   CFLAGS+=" -ffat-lto-objects"

+  # Fix libxml2 path
+  LIBS+=" -L/usr/lib/libxml2-2.9/ -L/usr/lib/libxslt -lxslt -lxml2"
+  CFLAGS+=" -I/usr/include/libxml2-2.9 -I/usr/include/libxml2-2.9/libxml2 -I/usr/include/libxslt -I/usr/include"
+
   # build
   ./configure "${options[@]}"
   make world
- -- 
2.43.0

-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQS1rLeeEfG/f0nzK7hYUwVpYvFOWAUCZXa+ywAKCRBYUwVpYvFO
WJJQAPwI2sp2OKIwuBttQAva1AnMWtWJeZOeTSmL0cgXH3NTJQEAw+iWgT5RtXon
lqxQjujndLZkwkJKTprPm+0ojGLUNww=
=j5wg
-----END PGP SIGNATURE-----

mrechte commented on 2023-12-08 11:02 (UTC) (edited on 2023-12-26 14:39 (UTC) by mrechte)

Introduction

This version may cohabit with other major versions, including the official one.

Data directory is /var/lib/postgres/data15

Initialize the database
su - postgres
. /opt/postgresql15/bin/pgenv.sh
initdb -k
Start the service
systemctl start postgresql15
Use the service
. /opt/postgresql15/bin/pgenv.sh
psql -U postgres