Package Details: prey-demo 02192009-1

Git Clone URL: https://aur.archlinux.org/prey-demo.git (read-only)
Package Base: prey-demo
Description: Prey is a first person shooter based on the id Tech 4 engine using portals and variable gravity (Demo Version).
Upstream URL: http://icculus.org/prey/
Licenses: custom
Submitter: Slash
Maintainer: Slash
Last Packager: Slash
Votes: 10
Popularity: 0.000428
First Submitted: 2008-10-25 20:07
Last Updated: 2015-06-08 17:49

Latest Comments

oneonfire commented on 2014-05-19 08:47

post_install() {
echo ">>> You must read and agree to the terms in the EULAs found"
echo ">>> in /usr/share/licenses/prey-demo/ before using this software!"
echo ">>> Remove old libraries"
rm /opt/prey-demo/libgcc_s.so.1
rm /opt/prey-demo/libSDL-1.2.so.0
rm /opt/prey-demo/libstdc++.so.5
echo ">>> Install symlinks to new libraries"
ln -s /usr/lib32/libSDL-1.2.so.0 /opt/prey-demo/libSDL-1.2.so.0
ln -s /usr/lib32/libopenal.so /opt/prey-demo/openal.so
ln -s /usr/lib32/libstdc++.so.5 /opt/prey-demo/libstdc++.so.5
}

post_upgrade() {
post_install $1
}

pre_remove() {
echo ">>> Remove symlinks to libSDL-1.2.so.0 and libopenal.so"
rm /opt/prey-demo/libSDL-1.2.so.0
rm /opt/prey-demo/openal.so
rm /opt/prey-demo/libstdc++.so.5
}

op=$1
shift

$op $*

oneonfire commented on 2014-05-19 08:08

My build script is not perfect, you can link to the library through the prey-demo.install

oneonfire commented on 2014-05-19 08:04

license=('custom')

oneonfire commented on 2014-05-19 08:04

License not GPL

oneonfire commented on 2014-05-19 08:02

# Contributor: Slash <youremail@domain.com>

pkgname=prey-demo
pkgver=02192009
pkgrel=2
pkgdesc="Prey is a first person shooter based on the id Tech 4 engine using portals and variable gravity (Demo Version)."
arch=('i686' 'x86_64')
url="http://icculus.org/prey/"
license=('GPL')
if [ "$CARCH" = "x86_64" ]; then
depends=('lib32-libstdc++5' 'lib32-libxext' 'lib32-openal')
else
depends=('libstdc++5' 'libxext' 'openal')
fi
makedepends=('unzip')
install=prey-demo.install
source=("prey-demo.desktop" "prey-demo.launcher" \
"http://icculus.org/prey/downloads/$pkgname-installer-$pkgver.bin")
md5sums=('076b4092529d9cc7d092c4630fced700'
'637b319535afb902d4645030153acfbe'
'dded67270bc59248f2b8fedd7d51156d')

package() {
# Extract Files
unzip $srcdir/$pkgname-installer-$pkgver.bin && true

# Create Destination Directory
install -d $pkgdir/opt/prey-demo/

# Install Game Files
cp -r $srcdir/data/prey-demo-linux-x86/* \
$pkgdir/opt/prey-demo/

# Install Data Files
cp -r $srcdir/data/prey-demo-linux-data/* \
$pkgdir/opt/prey-demo/

# Install Punkbuster Files
cp -r $srcdir/data/punkbuster-linux-x86/* \
$pkgdir/opt/prey-demo/

# Install Default Config
cp $srcdir/data/configs/english.cfg \
$pkgdir/opt/prey-demo/base/default.cfg

# Install License (Prey)
install -D -m 0644 $srcdir/data/prey_demo_license.txt \
$pkgdir/usr/share/licenses/$pkgname/prey_demo_license.txt

# Install License (Punkbuster)
install -D -m 0644 $srcdir/data/punkbuster_license.txt \
$pkgdir/usr/share/licenses/$pkgname/punkbuster_license.txt

# Install Desktop Shortcut
install -D -m 0644 $srcdir/prey-demo.desktop \
$pkgdir/usr/share/applications/prey-demo.desktop

# Install Client Launcher
install -D -m 0755 $srcdir/prey-demo.launcher \
$pkgdir/usr/bin/prey-demo

# Remove old libraries
rm ${pkgdir}/opt/prey-demo/libgcc_s.so.1
rm ${pkgdir}/opt/prey-demo/libSDL-1.2.so.0

# Install new libSDL-1.2.so to PREY directory
install -D -m 0644 /usr/lib32/libSDL-1.2.so.0 ${pkgdir}/opt/prey-demo/libSDL-1.2.so.0

# Install new libopenal.so to PREY directory
install -D -m 0644 /usr/lib32/libopenal.so ${pkgdir}/opt/prey-demo/openal.so
}

oneonfire commented on 2014-05-19 06:03

Game crashes - need to change PKGBUILD

Slash commented on 2011-12-06 00:26

Why was this flagged out of date?

jose1711 commented on 2010-09-04 16:08

unzip command needs "|| true" at the end now after changes to PKGBUILD handling