Package Details: prey-node-client 1.9.5-1

Git Clone URL: https://aur.archlinux.org/prey-node-client.git (read-only, click to copy)
Package Base: prey-node-client
Description: Remote tracking and monitoring application for laptops, smartphones, and other electronic devices
Upstream URL: https://preyproject.com/
Licenses: GPL3
Replaces: prey-tracker
Submitter: lutoma
Maintainer: xpt
Last Packager: xpt
Votes: 33
Popularity: 0.022963
First Submitted: 2014-12-02 03:20
Last Updated: 2020-08-24 16:21

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

konfou commented on 2016-03-19 15:18

@JDCNS It maybe has to do with the bundled nodejs being a different version than the system-wide installed. Right now the community/nodejs is v5.9.0 while the bundled is v0.10.36. This package removes this in favor of the system version. I was getting the same message and using the v0.10 node solved it.

JDCNS commented on 2016-03-09 02:11

So, am I the only one with this problem? I tried to run the post_install, and I get:

Error! Command failed: /usr/bin/node /opt/prey-node-client/node_modules/ocelot/runner.js prey /opt/prey-node-client/bin/prey config activate
internal/child_process.js:298
throw errnoException(err, 'spawn');
^

Error: spawn EACCES
at exports._errnoException (util.js:856:11)
at ChildProcess.spawn (internal/child_process.js:298:11)
at exports.spawn (child_process.js:367:9)
at run_command (/opt/prey-node-client/node_modules/ocelot/runner.js:60:15)
at Object.<anonymous> (/opt/prey-node-client/node_modules/ocelot/runner.js:95:1)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)

faustinoaq commented on 2016-03-05 08:52

Prey 1.5 was not working for me

I did this

# systemctl enable NetworkManager-wait-online.service

And I change target in prey-agent.service
...
After=network-online.target
...

EDIT: I had to restart prey-agent and works well.

I did a "prey-restart.timer" for restart "prey-agent" periodically

xpt commented on 2016-02-18 02:41

sha256sum's variables are changed and I change the name of /bin/prey to /bin/pre_proyect ( conflict with prey fps game)

jschorr commented on 2016-02-16 17:57

elv- just change the values of those two lines to have () around them.

zanny commented on 2016-02-15 16:05

Both this package and https://aur.archlinux.org/packages/prey/ (the fps) install themselves as /usr/bin/prey. One of you two should rename to avoid the unnecessary conflict, and technically prey the game came first (2008 vs 2009).

eang commented on 2016-02-09 18:47

I get the following errors:

* sha256sums_x86_64 should be an array
* sha256sums_i686 should be an array

I guess this is a change of pacman 5.0?

xpt commented on 2016-01-05 00:33

In the post_install script (prey-node-client.install) you run:
/opt/prey-node-client/bin/prey config hooks post_install >/dev/null

I don't know why you had to do by yourself.

wil93 commented on 2016-01-02 02:54

Isn't the 'prey-agent.service' unit file missing? I can't seem to find it.

EDIT: nevermind, apparently I had to run `sudo prey config hooks post_install` in order to install the unit file.

eang commented on 2015-09-27 08:13

The package fails to build if the build dir is set to /tmp/makepkg.

It should be enough to switch from ../../prey-node-client.patch to "${srcdir}/prey-node-client.patch", when applying the patch at line 31.