Package Details: prey-node-client 1.9.5-1

Git Clone URL: https://aur.archlinux.org/prey-node-client.git (read-only, click to copy)
Package Base: prey-node-client
Description: Remote tracking and monitoring application for laptops, smartphones, and other electronic devices
Upstream URL: https://preyproject.com/
Licenses: GPL3
Replaces: prey-tracker
Submitter: lutoma
Maintainer: xpt
Last Packager: xpt
Votes: 33
Popularity: 0.027171
First Submitted: 2014-12-02 03:20
Last Updated: 2020-08-24 16:21

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

xpt commented on 2015-06-11 02:33

thanks ThecaTTony :)

- for python2 I added a message in the post_install script
- i added to the patch file the NetworkManager issue

ThecaTTony commented on 2015-06-05 08:51

Prey needs python2, pygtk (messages and lock screen), NetworkManager (wifi-autoconnect) and a couple of hooks to run as expected.

1- Its python2 so its needs this workaraund:
https://wiki.archlinux.org/index.php/Python#Dealing_with_version_problem_in_build_scripts
(/opt/prey-node-client/*)

2- For restart NetworkManager daemon prey executes:
"service NetworkManager restart"
The script /usr/local/bin/service fix this:
#!/bin/bash
systemctl $2 $1

3- ssh-agent dont work on my system to get logged user's. Other programs that provide that are: gnome-keyring-daemon (gnome-keyring) and kde-authentication-agent (maybe polkit-kde?)

noplomplom commented on 2015-05-01 11:29

Cannot build the package. Error at line 31: ../../prey-node-client.patch: No such file or directory.

niq000 commented on 2015-04-30 17:52

thanks olantwin, i was having trouble getting this configured until I installed lsb-release. +1 that it should be added as a dependency and/or optional

xpt commented on 2015-04-28 19:24

ok, i added wireless_tools as a dependency

Anonymous comment on 2015-04-28 17:20

It seems that Prey also requires the package wireless_tools as it was not able to connect to their servers without iwlist.

lutoma commented on 2015-03-24 19:27

Dear all, sadly I don't have much time to maintain this right now, so I'm orphaning it. If noone picks it up, I might myself at some later point, but no promises.

shackra commented on 2015-03-19 21:01

NiNjA's workaround seems to work... or maybe upstream fixed the issue they had! IDK

olantwin commented on 2015-03-13 17:14

Can you add lsb-release as dependency (or optional)? The setup gui can't detect distro without it.

I also noticed the commented out provides line in the PKGBUILD. Now that the bash client is renamed, maybe uncomment it/add a conflict?

Thank you for maintaining this package.

NiNjA commented on 2015-03-09 16:48

It apparently helped to upgrade the linus nodejs package. I issued the following commands as root and now it seems to work as expected:

cd /opt/prey-node-client/node_modules
npm install linus