Package Details: promoe-git 0.2.0-1

Git Clone URL: https://aur.archlinux.org/promoe-git.git (read-only)
Package Base: promoe-git
Description: XMMS2 client that looks like Winamp Classic
Upstream URL: https://github.com/dsvensson/promoe
Licenses: GPL2
Submitter: xyproto
Maintainer: xyproto
Last Packager: xyproto
Votes: 18
Popularity: 0.011918
First Submitted: 2009-04-22 14:14
Last Updated: 2015-06-10 13:24

Latest Comments

Malvineous commented on 2015-12-27 05:16

Is this still working after the C++ ABI change? I can't compile this anymore as I get some static assert errors related to cxx11/basic_string:

../backend_xmmsclient++/xclient.cpp:169:55: required from here
/usr/include/boost/variant/get.hpp:195:48: error: invalid application of ‘sizeof’ to incomplete type ‘boost::STATIC_ASSERTION_FAILURE<false>’

I'm not sure whether the problem is with this package (not picking the new/old ABI), or with the code (not updated for the latest Boost or xmms2-devel). Any ideas?

I'm compiling against the latest xmms2-devel.git

xyproto commented on 2015-11-02 11:44

By building with "makepkg -A" there is no need to add arm to the arch array when building this package on Arch Linux ARM.

Malvineous commented on 2015-04-22 21:22

Great! Arch Linux ARM does use the same AUR though, unless I am mistaken? I was certainly using your PKGBUILD under ARM and it worked perfectly once adding the appropriate architectures.

xyproto commented on 2015-04-22 13:18

@Malvineous, Arch Linux currently (unfortunately) only supports i686 and x86_64. Arch Linux ARM, a completely different project, does support various ARM architectures, though.

Thanks for the link to the new location of the git repo!

Malvineous commented on 2015-04-08 05:40

Upstream git repo has moved to <git://github.com/dsvensson/promoe.git> and the arch=() line needs both 'armv6h' and 'armv7h' added to it (for the Raspberry Pi and Raspberry Pi 2, respectively.)

Malvineous commented on 2014-10-05 13:02

Sorry muddled thinking in my last message - the arch line should have "armv6h" added to it - you can't change it to "any" or it will build a special platform neutral package which is incorrect as the binaries are platform-specific.

Malvineous commented on 2014-10-03 16:08

Just realised that qt5-base is a dependency of this package, but it then passes a qt4 path to 'waf configure', and the build fails if qt4 isn't installed. It doesn't actually need qt5 at all. Could the "qt5-base" dependency be changed to "qt4"? This worked fine for me, but I did have to update /etc/xdg/qtchooser/default.conf to point to 4.conf rather than the default 5.conf (since qt5 was no longer installed, but this is a Qt config issue not a Promoe one.)

I also think the ARCH line should be changed to 'any' as it compiles fine on non-Intel architectures. I just compiled it on the armv6h architecture (a Raspberry Pi) so this x86_64/i686 restriction isn't really needed.

spk98 commented on 2014-02-16 15:57

yes, new pkgbuild builds fine - great!

xyproto commented on 2014-01-27 18:45

spk98, added --qtbin=/usr/lib/qt4/bin. Does it work for you now?

Builds fine here.

spk98 commented on 2014-01-26 15:08

re below build fail:
qt4 pkg places rcc in /usr/lib/qt4/bin/rcc
but build expects in /usr/bin or other standard place.
doing symlink: /usr/bin/rcc --> /usr/lib/qt4/bin/rcc
gets past this.

All comments