Package Details: prosody-hg-stable 0.10.r7499+.3d21c63ec03f+-1

Git Clone URL: (read-only)
Package Base: prosody-hg-stable
Description: Lightweight and extensible Jabber/XMPP server written in Lua (stable build from 0.10-branch)
Upstream URL:
Licenses: MIT
Conflicts: prosody
Provides: prosody
Submitter: TilmanV
Maintainer: None
Last Packager: TilmanV
Votes: 1
Popularity: 0.000001
First Submitted: 2016-01-24 22:57
Last Updated: 2017-12-01 23:00

Required by (27)

Sources (4)

Latest Comments

TilmanV commented on 2018-02-28 09:33

I won't maintain this package anymore.

TilmanV commented on 2017-03-07 19:52

fixed. jenkins will publish the fix soon.

tommy.mezei commented on 2017-03-04 13:16

The configure script finds the correct lua binary if --lua-suffix=5.1 is appended to the build flags.

sonny commented on 2017-03-04 12:29

Building started to fail yesterday after an update

==> Starting build()...
Lua version detected: 5.3
Lua interpreter found: /usr/bin/lua...
Checking Lua includes... lua.h found in /usr/include/lua5.1/lua.h
Checking if Lua header version matches that of the interpreter... no
lua.h version mismatch (interpreter: 5.3; lua.h: 5.1).
You may want to use the flag --with-lua or --with-lua-include. See --help.

configure failed.

==> ERROR: A failure occurred in build().
:: failed to build prosody-hg-stable package(s)

kseistrup commented on 2016-08-13 22:01

Perhaps it would be worth it if the XMPP server has a high load. I can't feel any difference on my prosody instance.

TilmanV commented on 2016-08-13 21:50

Fascinating! But would a prosody-hg-stable-luajit package be worth?

kseistrup commented on 2016-08-12 14:19

It seems to work:

prosody 18511 1.9 0.0 46168 8780 ? S 16:15 0:00 luajit /usr/lib/prosody/../../bin/prosody

However, in spite of what the prosody doc says you cannot say `configure --runwith=/usr/bin/luajit` because the slashes clash with a sed expression (could be solved by using ‘@’ instead of ‘/’), but `configure --runwith=luajit` works just fine.

kseistrup commented on 2016-08-12 14:11

This is what the prosody doc says about luajit:

Looks promising (haven't tried yet).

kseistrup commented on 2016-08-12 14:08

Thanks. I asked because I was thinking of installing a program (not in Arch or AUR) that requires luajit and saw that luajit was drop-in compatible, so I assumed (I should have checked, of course, but didn't) that lua51 and luajit were mutually exclusive.

If I find out, I'll post a notice here.

Thanks for your fast response.

TilmanV commented on 2016-08-12 12:39

hm. technically yes... but
- luajit doesn't provide "lua51", so you will have to install the lua51 package. (Its a dependency of all the lua-modules)
- "/usr/bin/env lua5.1" is set as the interpreter in "/usr/bin/prosodyctl". You'll have to change this.
- I have no clue if this will work 100%.

If you're going to test this, I would like to see the results.

All comments