Package Details: proxygen 2024.05.27.00-1

Git Clone URL: https://aur.archlinux.org/proxygen.git (read-only, click to copy)
Package Base: proxygen
Description: A collection of C++ HTTP libraries including an easy to use HTTP server
Upstream URL: https://github.com/facebook/proxygen
Keywords: c++ facebook http
Licenses: BSD-3-Clause
Provides: liblibhttperf2.so, libproxygen.so, libproxygencurl.so, libproxygendeviousbaton.so, libproxygenhqloggerhelper.so, libproxygenhttpserver.so
Submitter: dseg
Maintainer: MrAnno (carsme)
Last Packager: carsme
Votes: 4
Popularity: 0.057829
First Submitted: 2015-04-08 04:36 (UTC)
Last Updated: 2024-06-01 17:18 (UTC)

Latest Comments

jghodd commented on 2024-02-02 02:39 (UTC) (edited on 2024-02-02 04:08 (UTC) by jghodd)

getting the following warnings during the build, both of which are a bit disconcerting:


/bin/ld: warning: libfizz.so.2024.01.22.00, needed by /usr/lib/libmvfst_fizz_client.so.2024.01.29.00, not found (try using -rpath or -rpath-link)
/bin/ld: warning: libfolly.so.2024.01.22.00, needed by /usr/lib/libmvfst_fizz_client.so.2024.01.29.00, not found (try using -rpath or -rpath-link)

folly, fizz and wangle were all updated to 2024.01.29, so these link warnings suggest that the built software is going to attempt access to fizz and folly 2024.01.22. that's a bug.

Edit: doesn't build because of the library references

Edit2: confirmed with a clean build after running ldconfig and the build still fails due to unresolved references to fizz/folly 2024.01.22 - something is hard-coded to that version. also checked the contents of my ldconfig cache and it correctly contains references to fizz/folly 2024.01.29, so am not sure where this build is getting fizz/folly 2024.01.22 references

dseg commented on 2017-03-13 07:54 (UTC)

Just updated to the latest version. Built without errors, Looks good to me.

sleeping commented on 2017-03-12 02:12 (UTC)

configure: error: Please install the wangle library from https://github.com/facebook/wangle Missing dependency?