Package Details: psi-git 1.3_dev_20180117-1

Git Clone URL: (read-only, click to copy)
Package Base: psi-git
Description: A jabber client. GIT version
Upstream URL:
Licenses: GPL2
Conflicts: psi, psi-qt5-git
Replaces: psi, psi-qt5-git
Submitter: hcartiaux
Maintainer: None
Last Packager: hcartiaux
Votes: 3
Popularity: 0.000000
First Submitted: 2015-10-22 16:43 (UTC)
Last Updated: 2018-01-17 16:14 (UTC)

Latest Comments

1 2 3 Next › Last »

Martchus commented on 2018-01-09 13:57 (UTC)

On one more thing, the dependencies should be updated as well. Cmake should be a makedependency now and the dependencies qt5-svg, qt5-webkit and hunspell are missing. Seems like the CMake script is less tolerant if something is not available.

depends=('qca-qt5' 'qt5-x11extras' 'qt5-multimedia' 'qt5-svg' 'qt5-webkit' 'hunspell' 'aspell' 'libxss' 'minizip' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('git' 'cmake')

sir_lucjan commented on 2018-01-09 13:13 (UTC) (edited on 2018-01-09 13:15 (UTC) by sir_lucjan)


You should update .SRCINFO


No problem. Always a pleasure.

hcartiaux commented on 2018-01-09 13:07 (UTC)

@sir_lucjan Thank you, updated

Martchus commented on 2018-01-09 12:22 (UTC)

@sir_lucjan Thanks!

sir_lucjan commented on 2018-01-08 20:45 (UTC) (edited on 2018-01-08 21:13 (UTC) by sir_lucjan)

@Martchus @hcartiaux

psi-git with cmake


Martchus commented on 2018-01-07 19:31 (UTC)

@sir_lucjan BTW: You seem to come further than me when using qmake. This unhelpful message Error: need Generate .prl files! likely means that dependencies are missing. You can add --verbose to the configure line for further investigation (

Martchus commented on 2018-01-07 19:27 (UTC)

I'm also unable to build the latest commit. Here it does not even find qmake despite the fact that qmake and qmake-qt5 are both in PATH. That is likely an upstream issue but switching to CMake might help, indeed.

@sir_lucjan I'm linking your issue about that approach here:

sir_lucjan commented on 2018-01-06 21:22 (UTC)

==> Starting pkgver()... ==> Updated version: psi-git 1.3_dev_20180106-1 ==> Starting build()... Project name: Psi Profile: Deps: qt5 buildmodeapp idn qca zlib qjdns x11 universal qdbus keychain qtmultimedia qtconcurrent qtwidgets qtnetwork qtxml webkit growl whiteboarding xss aspell enchant hunspell spell plugins conf recursiveprl*

'configure' written. 'configure.exe' written. Configuring Psi ... Verifying Qt build environment ... ok Checking for Qt >= 5.0.0 ... 5.10.0 Checking for LibIDN ... yes Checking for QCA >= 2.0 ... yes Checking for zlib ... yes Checking for QJDns ... Disabled for Qt5 and above Checking for QtDbus ... yes Checking for Qt Keychain ... yes Checking for QtMultimedia ... yes Checking for QtConcurrent ... yes Checking for QtWidgets ... yes Checking for QtNetwork ... yes Checking for QtXml ... yes Checking for the XScreenSaver extension ... yes Checking for spellcheck engine ... aspell Checking for Psi Plugin support ... yes Generating .prl files ... fail

Error: need Generate .prl files!

Probably you should switch to cmake.

grinderz commented on 2017-08-29 05:53 (UTC)

successfully installed Psi v1.2-dev, thanks.