Package Details: psi-git 1.3_dev_20180117-1

Git Clone URL: https://aur.archlinux.org/psi-git.git (read-only)
Package Base: psi-git
Description: A jabber client. GIT version
Upstream URL: http://psi-im.org/
Licenses: GPL2
Conflicts: psi, psi-qt5-git
Replaces: psi, psi-qt5-git
Submitter: hcartiaux
Maintainer: hcartiaux
Last Packager: hcartiaux
Votes: 3
Popularity: 0.005066
First Submitted: 2015-10-22 16:43
Last Updated: 2018-01-17 16:14

Latest Comments

Martchus commented on 2018-01-09 13:57

On one more thing, the dependencies should be updated as well. Cmake should be a makedependency now and the dependencies qt5-svg, qt5-webkit and hunspell are missing. Seems like the CMake script is less tolerant if something is not available.

depends=('qca-qt5' 'qt5-x11extras' 'qt5-multimedia' 'qt5-svg' 'qt5-webkit' 'hunspell' 'aspell' 'libxss' 'minizip' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('git' 'cmake')

sir_lucjan commented on 2018-01-09 13:13

@hcartiaux

You should update .SRCINFO

:)

No problem. Always a pleasure.

hcartiaux commented on 2018-01-09 13:07

@sir_lucjan Thank you, updated

Martchus commented on 2018-01-09 12:22

@sir_lucjan Thanks!

sir_lucjan commented on 2018-01-08 20:45

@Martchus @hcartiaux

psi-git with cmake

https://pastebin.com/uiaSYQ6k

Works.

Martchus commented on 2018-01-07 19:31

@sir_lucjan BTW: You seem to come further than me when using qmake. This unhelpful message Error: need Generate .prl files! likely means that dependencies are missing. You can add --verbose to the configure line for further investigation (https://github.com/psi-im/psi/issues/275).

Martchus commented on 2018-01-07 19:27

I'm also unable to build the latest commit. Here it does not even find qmake despite the fact that qmake and qmake-qt5 are both in PATH. That is likely an upstream issue but switching to CMake might help, indeed.

@sir_lucjan I'm linking your issue about that approach here: https://github.com/psi-im/psi/issues/338

sir_lucjan commented on 2018-01-06 21:22

==> Starting pkgver()... ==> Updated version: psi-git 1.3_dev_20180106-1 ==> Starting build()... Project name: Psi Profile: psi.pro Deps: qt5 buildmodeapp idn qca zlib qjdns x11 universal qdbus keychain qtmultimedia qtconcurrent qtwidgets qtnetwork qtxml webkit growl whiteboarding xss aspell enchant hunspell spell plugins conf recursiveprl*

'configure' written. 'configure.exe' written. Configuring Psi ... Verifying Qt build environment ... ok Checking for Qt >= 5.0.0 ... 5.10.0 Checking for LibIDN ... yes Checking for QCA >= 2.0 ... yes Checking for zlib ... yes Checking for QJDns ... Disabled for Qt5 and above Checking for QtDbus ... yes Checking for Qt Keychain ... yes Checking for QtMultimedia ... yes Checking for QtConcurrent ... yes Checking for QtWidgets ... yes Checking for QtNetwork ... yes Checking for QtXml ... yes Checking for the XScreenSaver extension ... yes Checking for spellcheck engine ... aspell Checking for Psi Plugin support ... yes Generating .prl files ... fail

Error: need Generate .prl files!

Probably you should switch to cmake.

grinderz commented on 2017-08-29 05:53

successfully installed Psi v1.2-dev, thanks.

hcartiaux commented on 2017-05-08 09:57

@Martchus: thanks, I have updated the dependencies.

Martchus commented on 2017-05-07 15:16

The error is caused by missing dependency `qt5-multimedia` (used --verbose on the configure line to get a more helpful message). You probably didn't notice because you didn't build in a clean chroot.

Martchus commented on 2017-05-05 12:03

Thanks for updating, but I'm still getting an error:

```
==> Starting build()...
Project name: Psi
Profile: psi.pro
Deps: qt4* buildmodeapp* idn* qca* zlib* qjdns* x11* universal qdbus webkit growl whiteboarding xss aspell enchant hunspell spell* plugins conf* recursiveprl*

'configure' written.
'configure.exe' written.
Configuring Psi ...
Verifying Qt build environment ... ok
Checking for Qt >= 4.7.0 ... 5.8.0
Checking for LibIDN ... yes
Checking for QCA >= 2.0 ... yes
Checking for zlib ... yes
Checking for QJDns ... yes
Checking for QDBUS ... yes
Checking for the XScreenSaver extension ... yes
Checking for spellcheck engine ... aspell
Checking for Psi Plugin support ... yes
Generating .prl files ... fail

Error: need Generate .prl files!

==> ERROR: A failure occurred in build().
```

Martchus commented on 2017-05-02 20:37

Does not work anymore:

```
Deps: qt4* buildmodeapp* idn* qca* zlib* qjdns* x11* universal qdbus webkit growl whiteboarding xss aspell enchant hunspell spell* plugins conf* recursiveprl*

'configure' written.
'configure.exe' written.
patching file configure
Hunk #1 succeeded at 1089 with fuzz 2 (offset 7 lines).
Configuring Psi ...
Verifying Qt build environment ... fail

Reason: Unable to find the 'qmake' tool for Qt 4 or 5.

Be sure you have a proper Qt 4.0+ build environment set up. This means not
just Qt, but also a C++ compiler, a make tool, and any other packages
necessary for compiling C++ programs.

If you are certain everything is installed, then it could be that Qt is not
being recognized or that a different version of Qt is being detected by
mistake (for example, this could happen if $QTDIR is pointing to a Qt 3
installation). At least one of the following conditions must be satisfied:

1) --qtdir is set to the location of Qt
2) $QTDIR is set to the location of Qt
3) QtCore is in the pkg-config database
4) qmake is in the $PATH

This script will use the first one it finds to be true, checked in the above
order. #3 and #4 are the recommended options. #1 and #2 are mainly for
overriding the system configuration.

==> ERROR: A failure occurred in build().
```

Maybe the build script attempts to find Qt 4 but Psi actually uses Qt 5 now?

sl1pkn07 commented on 2015-10-22 17:16

please remove qt5-base (pulled by qt5-x11extras & qca-qt5)

and add

'minizip'
'desktop-file-utils'
'hicolor-icon-theme'

and add a .install file with:

http://sl1pkn07.wtf/paste/view/1dde9aad

greetings

sl1pkn07 commented on 2015-10-22 17:13

when launch:

http://sl1pkn07.wtf/paste/view/9a9de953

spawn a error window (and close it) with (unique) cancel button

"Unable to load iconset! please make sure Psi is properly installed"

greetings

hcartiaux commented on 2015-10-22 17:03

I've just fixed the PKGBUILD, and the package will soon be renamed psi-git

ozky commented on 2015-10-22 16:26

Thanks no problem i can just use that psi plus as it's working fine and builds.

hcartiaux commented on 2015-10-22 15:25

I'm aware of the issue, I just don't have enough free time to fix it.

I've already tried merging the PKGBUILD from psi-plus-git, but it does not solve the issue. It seems to be related to the build script when using qt5.

ozky commented on 2015-10-22 15:03

This pkgbuild is dead end it lacks many libaries to get it build.
This can be fixed as psi plus git have right sources and deps,so hcartiaux take a look that one.
https://aur.archlinux.org/packages/psi-plus-git/

ozky commented on 2015-10-21 09:45

I got error building this.
/usr/bin/ld: ei löydy kohdetta -lirisnet
collect2: virhe: ld:n paluuarvo oli 1
Makefile:1523: recipe for target '/home/ozky/qutim-qt5-git/psi-qt5-git/src/psi/psi' failed
make[1]: *** [/home/ozky/qutim-qt5-git/psi-qt5-git/src/psi/psi] Error 1
make[1]: Leaving directory '/home/ozky/qutim-qt5-git/psi-qt5-git/src/psi/src'
Makefile:80: recipe for target 'sub-src-install_subtargets' failed
make: *** [sub-src-install_subtargets] Error 2
==> VIRHE: Virhe tapahtui funktiossa package().