Package Details: pspp 0.10.2-1

Git Clone URL: (read-only)
Package Base: pspp
Description: Statistical analysis program. Free replacement for SPSS.
Upstream URL:
Licenses: GPL3
Submitter: escondida
Maintainer: migrev
Last Packager: migrev
Votes: 66
Popularity: 1.238343
First Submitted: 2008-10-14 00:20
Last Updated: 2016-07-24 16:36

Latest Comments

ulke commented on 2016-02-26 14:04

Since the update of postgresql-libs to 9.5 "save outfile" commands in pspp often fail silently. No file gets written. I have downgraded postgresql-libs to 9.4.5-1 and it works again.

Maybe the package should depend only on the older postgresql versions (9.3 and/or lts)?

MrX commented on 2016-01-21 09:07

@xF0E: I just ran into the same problem. In my case, it was apparently caused by a user-local Perl library. `unset PERL5LIB PERL_LOCAL_LIB_ROOT PERL_MB_OPT PERL_MM_OPT` did the trick.

xF0E commented on 2016-01-18 11:36

@migrev: thanks!

I cheked the perl istallation(in fact have reinstalled it), perl seems to be fine.

ls /usr/share/perl5/core_perl/ExtUtils/Constant*


I'm able to compile the package if i pass --without-perl-module to ./configure. But still can't compile with perl module enabled.

migrev commented on 2016-01-15 15:41

@xF0E: Please check if you have perl correctly installed, especially if /usr/share/perl5/core_perl/ExtUtils/Constant* are present in your filesystem. Please post your results here to modify the PKGBUILD if needed. Thanks.

xF0E commented on 2016-01-14 19:22

The build process is failing with:

Checking if your kit is complete...
Warning: the following files are missing in your kit:
Please inform the author.
Only one of PREFIX or INSTALL_BASE can be given. Not both.
Makefile:12471: recipe for target 'perl-module/Makefile' failed
make[3]: *** [perl-module/Makefile] Error 25
make[3]: Leaving directory '/tmp/builddir/pspp/src/pspp-0.8.5'
Makefile:12479: recipe for target 'perl_module_tarball' failed
make[2]: *** [perl_module_tarball] Error 2

What can i do about it?

intelfx commented on 2015-09-11 13:37

The build process apparently fails when linking final executables due to unresolved symbols from libxml2 (there is no libxml2 in the linker command line).

I've patched the makefile:

orschiro commented on 2015-01-06 11:58

Someone having the same issue with integrity check failing?

==> Missing dependencies:
-> postgresql-libs
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
:: failed to verify pspp integrity

Sascha commented on 2014-10-23 15:45

This program isn't found when you search like this:

packer -Ss spss

Instead, you only find pspp-git. Could you add "free replacement for SPSS" to the package description?


anderraso commented on 2014-02-21 17:38

It works great! Thanks!

msx commented on 2013-11-10 04:22

Thank you very much for this package to everyone involved.

escondida commented on 2013-08-08 15:49

Disowned: I no longer use pspp. Sorry for the delay between the new release and the disown.

escondida commented on 2012-12-13 06:51

The current stable version does not; I believe that one is available in the developer snapshot and therefore, of course, in the git as well.

'Til the next stable version is released, if you need a .desktop file you can either write your own (easy enough to do) or download the official one from the project's git.

graysky commented on 2012-12-12 19:35

Ah... psppire is the gui. Do they not ship with .desktop files?

graysky commented on 2012-12-12 19:32

CLI only? I thought pspp ships with a GUI?

Anonymous comment on 2011-09-20 16:19

looks like the ftp mirror went down
changing to fixed the problem for me.

escondida commented on 2010-11-10 04:28

(Thanks to Alex for the patch)

escondida commented on 2010-11-07 00:12

The latest PKGBUILD & patch should fix the compilation

Also cleaned up the PKGBUILD a bit

Anonymous comment on 2010-10-12 19:42

It doesn't compile on my system:
Linux corfu 2.6.35-ARCH #1 SMP PREEMPT Wed Sep 29 08:45:18 CEST 2010 x86_64 AMD Phenom(tm) II X4 945 Processor AuthenticAMD GNU/Linux.

These are the last lines of the output:
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I./gl -I./gl -I./src/language/stats -I./src/language/expressions -I./src/language/expressions -I./src -I./lib -DPKGDATADIR=\"/usr/share/pspp\" -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -Wall -march=x86-64 -mtune=generic -O2 -pipe -Wdeclaration-after-statement -MT lib/gtksheet/lib_gtksheet_libgtksheet_a-gtkitementry.o -MD -MP -MF lib/gtksheet/.deps/lib_gtksheet_libgtksheet_a-gtkitementry.Tpo -c -o lib/gtksheet/lib_gtksheet_libgtksheet_a-gtkitementry.o `test -f 'lib/gtksheet/gtkitementry.c' || echo './'`lib/gtksheet/gtkitementry.c
lib/gtksheet/gtkitementry.c:148:21: error: declaración static de ‘gtk_entry_reset_im_context’ después de una declaración que no es static
/usr/include/gtk-2.0/gtk/gtkentry.h:311:13: nota: la declaración previa de ‘gtk_entry_reset_im_context’ estaba aquí
lib/gtksheet/gtkitementry.c:2196:1: aviso: se define ‘gtk_entry_update_primary_selection’ pero no se usa
make[2]: *** [lib/gtksheet/lib_gtksheet_libgtksheet_a-gtkitementry.o] Error 1
make[2]: se sale del directorio `/home/pepe/config/builds/pspp/src/pspp-0.6.2'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/home/pepe/config/builds/pspp/src/pspp-0.6.2'
make: *** [all] Error 2

td123 commented on 2010-07-17 20:58

Just a few things to take into account,
perl, texinfo, pkgconfig are already provided by base/base-devel so you don't need to have the makedepends line.

Also, you don't need the " || return 1"s anymore in the PKGBUILD


escondida commented on 2010-07-03 04:01

pkgrel bump to -3.

The PKGBUILD now takes advantage of the new package() function.