Package Details: psychonauts 20130506-1

Git Clone URL: https://aur.archlinux.org/psychonauts.git (read-only)
Package Base: psychonauts
Description: A mind-bending platforming adventure (game sold separately)
Upstream URL: http://www.psychonauts.com/
Licenses: custom
Submitter: ejona86
Maintainer: ejona86
Last Packager: ejona86
Votes: 12
Popularity: 0.000000
First Submitted: 2012-06-02 20:21
Last Updated: 2015-06-20 16:14

Latest Comments

C5OK5Y commented on 2013-07-11 10:18

@ejona86: The current method of extracting the the Mojo Installer could be improved in a way that, as unzip always returns 1 (the Mojo Installer isn't a valid ZIP file), it is only continued when unzip returns 0 (improbable) or 1. This is useful because unzip can return various values which can point to real issues - in those cases it is best to abort the build. The code:

# if unzip returns a value different from 0, save it to $_return
unzip -o "${_gamepkg}" -d "${pkgname}-${pkgver}" || _return=$?
# if $_return is set and is not equal to "1", exit
[ $_return ] && [ ! $_return -eq "1" ] && exit 1 || true

It is possible that 'exit 1' could be replaced by 'return 1' but I haven't tested it (tell me if you do!).

ejona86 commented on 2013-07-03 15:11

@alex404. This package simply depends on openal. However, openal can use alsa, pulseaudio, or oss. Similarly, if you use alsa for openal by installing alsa-plugins, alsa can use optionally use pulseaudio and jack. It all depends on your configuration.

alex404 commented on 2013-06-27 18:51

Hey, I had to install alsa-oss to get this to work. You may want to make it a dependency.

Baumi commented on 2013-05-10 16:17

New Version is availabe by Humble Bundle

pkgver=20130508
srcpkgver=05062013

md5sum: 'cd207acda0613cf06bc153b4b85dceb3'

TheCycoONE commented on 2013-01-08 01:45

0.6 aka 01042012 is now on the humble bundle site.

fettouhi commented on 2012-10-22 18:04

Has anyone been able to find psychonauts version 0.6 anywhere? It is mentioned here

https://bugzilla.icculus.org/show_bug.cgi?id=5779

but I can't find it anywhere.

fettouhi commented on 2012-08-16 06:15

New build of Psychonauts is out.

joshgillies commented on 2012-07-18 11:13

I got the following output:

STUBBED: fix up the rest of the SSE code first at DetectSSESupport (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/MathGeneral.cpp:32)
STUBBED: write me? at SetPCLanguage (/home/icculus/projects/psychonauts/Source/game/luatest/UnixMain.cpp:120)
STUBBED: fix up the rest of the SSE code first at DetectCPUCaps (/home/icculus/projects/psychonauts/Source/game/luatest/Game/PCGameApp.cpp:223)
STUBBED: check LANG envr var at _GetDefaultGameLanguage (/home/icculus/projects/psychonauts/Source/game/luatest/Game/GameApp.cpp:171)
Console created
Save path: /home/josh/.local/share/Psychonauts
Write path: WorkResource
STUBBED: inline asm at SSEMul_4x4_4x4_2arg (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:710)
STUBBED: inline asm at SSEMul_4x4_4x4_3arg (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:698)
******** unit test failed ********
Transport started
DaveD: NCListenSocket: Listening on port 40001
STUBBED: VK_* at InitInputNames (/home/icculus/projects/psychonauts/Source/CommonLibs/DirectX/SDLInput.cpp:1220)
No joysticks detected
ERROR: Missing required OpenGL extensions:
- GL_EXT_texture_compression_s3tc
Start Up completed in 3.86 seconds
/usr/bin/psychonauts: line 3: 13254 Segmentation fault ./Psychonauts

Managed to get past this seg fault by installing "lib32-libtxc_dxtn libtxc_dxtn" from AUR.

But then ran into the following:

Found OpenAL device: 'OpenAL Soft'
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
AL lib: alsa_open_playback: Could not open playback device 'default': No such device or address

Installed lib32-alsa-plugins alsa-plugins lib32-pulse

and it now runs at least. But performance is not so great.

Any ideas?

Anonymous comment on 2012-07-11 23:29

I am running Arch 64 with the ati catalyst driver from the catalyst repository.
In order for psychonauts to work for me, I needed to install lib32-catalyst-utils (there was some error with libGL.so.1)
Furthermore, it wouldn't start because it whined about /dev/dsp not existing (I use pulseaudio), so I needed to install lib32-libpulse in order to fix that.
Perhaps you could add these packages as dependencies.
Kind regards,
asd

fettouhi commented on 2012-07-10 17:54

Can anyone get past Waterloo World? The game constantly crashes for me when entering this world.

All comments