Package Details: ptpython 3.0.23-2

Git Clone URL: https://aur.archlinux.org/ptpython.git (read-only, click to copy)
Package Base: ptpython
Description: Python REPL build on top of prompt_toolkit
Upstream URL: https://github.com/prompt-toolkit/ptpython
Licenses: BSD
Provides: ptpython3
Submitter: None
Maintainer: kwrazi
Last Packager: kwrazi
Votes: 23
Popularity: 0.45
First Submitted: 2016-01-14 03:17 (UTC)
Last Updated: 2023-03-15 14:50 (UTC)

Latest Comments

1 2 3 Next › Last »

typecasto commented on 2023-03-10 01:07 (UTC)

Seems like it needs to depend on python-appdirs, I can't get ptpython to run without installing it.

Freed commented on 2022-10-24 01:06 (UTC)

ptpython don't need python-docopt

syimyuzya commented on 2021-01-09 13:38 (UTC)

Looks like it depends on python-black as of version 3.0.9.

lk1234 commented on 2020-12-05 15:52 (UTC)

This package needs a rebuild for python 3.9.

potatoe commented on 2020-02-01 16:39 (UTC)

Can't flag-notify this, but it looks like ptpython 3.0.0 was just released January 29th: https://pypi.org/project/ptpython/3.0.0/ -- It seems to build fine with just an update of the new download URL and hash!

It looks like support for python2 has been dropped, so the PKGBUILD can be simplified a bit. I suppose if anyone still wants a package for python2 you could clone this current version as a separate ptpython2 AUR package that's left pegged to 2.0.5 (or 2.0.6 if you want working ipython support) and then update this to be python 3 only.

yodaembedding commented on 2020-01-19 09:58 (UTC) (edited on 2020-01-19 09:59 (UTC) by yodaembedding)

My personal workaround:

ROOT="$HOME/.cache/custom_pkgs"
mkdir -p "$ROOT"
cd "$ROOT"
git clone https://github.com/jonathanslenders/ptpython
cd ptpython
virtualenv env --system-site-packages
source env/bin/activate
python setup.py install

Now I create a script in SCRIPT_PATH, which is accessible from my PATH:

SCRIPT_PATH=~/.local/bin/ptpython
echo "#!/bin/bash
source '$ROOT/ptpython/env/bin/activate'
python -m ptpython" > "$SCRIPT_PATH"
chmod +x "$SCRIPT_PATH"

potatoe commented on 2019-12-07 17:13 (UTC) (edited on 2019-12-07 17:13 (UTC) by potatoe)

@lrustand: It's not just the requirements' versioning blocking it from working on 3.0, the code requires a moderate amount of updating which doesn't appear to be merged-in/finished yet: https://github.com/prompt-toolkit/ptpython/pull/309 and https://github.com/prompt-toolkit/ptpython/tree/prompt-toolkit-3.0

lrustand commented on 2019-12-02 15:51 (UTC)

I get an error when starting ptpython "The 'prompt_toolkit<2.1.0,>=2.0.8' distribution was not found and is required by ptpython". The current version of python-prompt_toolkit in community is 3.0.2-1. Could you update the version requirement so it works with the current version of prompt toolkit?

pepper_chico commented on 2018-12-01 00:44 (UTC) (edited on 2018-12-01 00:45 (UTC) by pepper_chico)

@wbthomason, right thanks!, it was a matter of patching my old ~/.ptpython/config.py, changing input_processor to key_processor.

wbthomason commented on 2018-11-30 21:23 (UTC)

@pepper_chico: You probably need to modify your ptpython config; that module doesn't exist with prompt_toolkit-2 (I'm unfortunately not sure what the replacement is). When you use the ptpython setup wizard, it imports that module in your config to set up vi mode.