Package Details: ptpython 2.0.4-3

Git Clone URL: https://aur.archlinux.org/ptpython.git (read-only)
Package Base: ptpython
Description: Python REPL build on top of prompt_toolkit
Upstream URL: https://github.com/jonathanslenders/ptpython
Licenses: BSD
Provides: ptpython3
Submitter: carlwgeorge
Maintainer: kwrazi
Last Packager: kwrazi
Votes: 12
Popularity: 0.010604
First Submitted: 2016-01-14 03:17
Last Updated: 2018-11-20 13:50

Latest Comments

1 2 Next › Last »

pepper_chico commented on 2018-12-01 00:44

@wbthomason, right thanks!, it was a matter of patching my old ~/.ptpython/config.py, changing input_processor to key_processor.

wbthomason commented on 2018-11-30 21:23

@pepper_chico: You probably need to modify your ptpython config; that module doesn't exist with prompt_toolkit-2 (I'm unfortunately not sure what the replacement is). When you use the ptpython setup wizard, it imports that module in your config to set up vi mode.

pepper_chico commented on 2018-11-30 15:55

I get "No module named 'prompt_toolkit.key_binding.input_processor'" when starting. Can't use it vi mode.

kseistrup commented on 2018-11-20 11:34

There is now

community/python2-prompt_toolkit 2.0.7-1

Could you please change dependency of

python2-prompt_toolkit-2>=2.0.6

?

wbthomason commented on 2018-11-15 03:35

@bartus: Good idea. For now, I just modified the PKGBUILD for ipython and ipython2 and jupyter_console to work with prompt_toolkit v2 instead.

bartus commented on 2018-11-14 16:05

@wbthomason: Just poke the maintainers of community repo to update ipython 6.5->7.1 ;) which uses prompt_toolkit v2.*

kwrazi commented on 2018-11-08 10:37

Try using virtualenv with pip.

wbthomason commented on 2018-11-07 18:15

python-prompt_toolkit-2 conflicts with python-prompt_toolkit, which is a dependency of ipython. This seems to make it impossible to use ptipython, since it precludes having both ipython and ptpython installed at the same time. Does anyone have a recommended solution?

kwrazi commented on 2018-11-07 02:03

Version 2.0.4 requires python-prompt_toolkit-2 >= 2.0.6. Until that package is updated, you will need to manually edit python-prompt_toolkit-2 to use 2.0.7. A sample PKGBUILD can be found here @pastebin.

polyzen commented on 2017-11-26 21:22

Poked the package maintainer and the issue is now resolved: https://bugs.archlinux.org/task/56396