Package Details: pulseaudio-ctl 1.67-1

Git Clone URL: https://aur.archlinux.org/pulseaudio-ctl.git (read-only)
Package Base: pulseaudio-ctl
Description: Control pulseaudio volume from the shell or mapped to keyboard shortcuts.
Upstream URL: https://github.com/graysky2/pulseaudio-ctl
Licenses: MIT
Conflicts: pulseaudio_ctl
Replaces: pulseaudio_ctl
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 188
Popularity: 1.941222
First Submitted: 2013-10-11 23:09
Last Updated: 2019-09-12 19:28

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

joshskidmore commented on 2019-09-12 19:40

@graysky - Works perfectly! Thanks for the quick fix.

graysky commented on 2019-09-12 19:29

@josh @Swipte - thanks for reporting and for the proposed fix. Fixed in 1.67. Please try can report back. In the future, open an issue on the github page rather then in the AUR.

ElVino commented on 2019-09-12 18:43

@joshskidmore the repo is located here: https://github.com/graysky2/pulseaudio-ctl

joshskidmore commented on 2019-09-12 17:03

pulseaudio-ctl is a bash script. The author is using a pretty rough regexp and bc to check pactl versions. The latest version of pulseaudio is 12.99.3 and bc cannot properly interpret the .3. You can fix this (temporarily) by replacing line 39 in /usr/bin/pulseaudio-ctl with:

PAVERSION=$(pactl --version | grep pactl | sed -e 's/^pactl //' -e 's/\([0-9.]\+\).\([0-9.]\+\)$/\1/')

I would submit a pull request to the author's repo, but it appears abandoned?

Swipe commented on 2019-09-12 13:00

I'm getting this error today after an upgrade to pulseaudio: upgraded pulseaudio (12.2-2 -> 12.99.3-1)

$ /usr/bin/pulseaudio-ctl up (standard_in) 1: syntax error (standard_in) 1: syntax error (standard_in) 1: syntax error Cannot determine which version of pactl is installed. Aborting.

Downgrading pulseaudio and libpulse fixes this.

atopia commented on 2017-09-20 08:01

1.66-1 fixes the problem for me. Thanks!

graysky commented on 2017-09-19 19:29

Please try 1.66-1

atopia commented on 2017-09-19 14:38

Problem persists with 1.65.1:
$ pacman -Q pulseaudio
pulseaudio 11.0+6+g01f489c3-1
$ pacman -Q pulseaudio-ctl
pulseaudio-ctl 1.65-1
$ pulseaudio-ctl up
Invalid volume specification
$ pulseaudio-ctl full-status
90 yes yes

muchweb commented on 2017-09-19 10:59

@graysky, `1.65-1` fixed problem

Anonymous comment on 2017-09-19 04:07

The issue seems to be with a new version of pulseaudio package, pactl has the following version string:
$ pactl --version
pactl 11.0-6-g01f48
[...]

Which makes it fall into the wrong case during the version comparison (should be PCV=2, but actually ends up PCV=1):
PAVERSION=$(pactl --version | grep pactl | sed 's/^pactl //')
if [[ ${PAVERSION%%.*} -lt 5 ]]; then
# really old versions
PCV=0
elif [[ 1 -eq "$(echo "${PAVERSION} > 10.9" | bc)" ]]; then
# since v11, they reverted the -- requirement
PCV=2
elif [[ 1 -eq "$(echo "${PAVERSION} > 5.1" | bc)" ]]; then
# version is upstream 5.99.2 or higher
PCV=2
elif [[ 1 -eq "$(echo "${PAVERSION} < 5.1" | bc)" ]]; then
# version is upstream 5.0
PCV=1
fi

So then it uses the old "set -- perc" syntax.