Package Details: pulseaudio-ctl 1.66-1

Git Clone URL: https://aur.archlinux.org/pulseaudio-ctl.git (read-only)
Package Base: pulseaudio-ctl
Description: Control pulseaudio volume from the shell or mapped to keyboard shortcuts.
Upstream URL: https://github.com/graysky2/pulseaudio-ctl
Licenses: MIT
Conflicts: pulseaudio_ctl
Replaces: pulseaudio_ctl
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 176
Popularity: 1.448340
First Submitted: 2013-10-11 23:09
Last Updated: 2017-09-19 19:29

Latest Comments

atopia commented on 2017-09-20 08:01

1.66-1 fixes the problem for me. Thanks!

graysky commented on 2017-09-19 19:29

Please try 1.66-1

atopia commented on 2017-09-19 14:38

Problem persists with 1.65.1:
$ pacman -Q pulseaudio
pulseaudio 11.0+6+g01f489c3-1
$ pacman -Q pulseaudio-ctl
pulseaudio-ctl 1.65-1
$ pulseaudio-ctl up
Invalid volume specification
$ pulseaudio-ctl full-status
90 yes yes

muchweb commented on 2017-09-19 10:59

@graysky, `1.65-1` fixed problem

zandive commented on 2017-09-19 04:07

The issue seems to be with a new version of pulseaudio package, pactl has the following version string:
$ pactl --version
pactl 11.0-6-g01f48
[...]

Which makes it fall into the wrong case during the version comparison (should be PCV=2, but actually ends up PCV=1):
PAVERSION=$(pactl --version | grep pactl | sed 's/^pactl //')
if [[ ${PAVERSION%%.*} -lt 5 ]]; then
# really old versions
PCV=0
elif [[ 1 -eq "$(echo "${PAVERSION} > 10.9" | bc)" ]]; then
# since v11, they reverted the -- requirement
PCV=2
elif [[ 1 -eq "$(echo "${PAVERSION} > 5.1" | bc)" ]]; then
# version is upstream 5.99.2 or higher
PCV=2
elif [[ 1 -eq "$(echo "${PAVERSION} < 5.1" | bc)" ]]; then
# version is upstream 5.0
PCV=1
fi

So then it uses the old "set -- perc" syntax.

Cake commented on 2017-09-19 01:58

I have the same issue (Invalid volume specification).

$ pulseaudio-ctl full-status
14 no no
$ pulseaudio-ctl up
Invalid volume specification
$ pulseaudio-ctl up 3
Invalid volume specification
$ pulseaudio-ctl --version
pulseaudio-ctl v1.65
...
Pulse version : 11.0-6-g01f48

skunktrader commented on 2017-09-19 00:42

Same issue (Invalid volume specification) with 1.65-1 here

graysky commented on 2017-09-18 20:05

@muchweb and Haron - please try 1.65-1.

muchweb commented on 2017-09-18 14:22

Stopped working after update

$ pulseaudio-ctl down
Invalid volume specification
$ pulseaudio-ctl up
Invalid volume specification

Mute works though

Haron_Prime commented on 2017-09-18 13:33

Don't work after update pulseaudio and libpulse

pulseaudio-ctl down
Invalid volume value.
pulseaudio-ctl up
Invalid volume value.

pulseaudio 11.0+6+g01f489c3-1
libpulse 11.0+6+g01f489c3-1
pulseaudio-ctl 1.64-1

All comments