Package Details: puppet-lint 2.5.2-1

Git Clone URL: (read-only, click to copy)
Package Base: puppet-lint
Description: Check that your Puppet manifests conform to the style guide.
Upstream URL:
Keywords: linter
Licenses: MIT
Submitter: joschi
Maintainer: kmille
Last Packager: kmille
Votes: 21
Popularity: 0.135267
First Submitted: 2012-03-04 11:10 (UTC)
Last Updated: 2022-02-10 09:50 (UTC)

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

krzyszto commented on 2022-02-09 14:12 (UTC)

version 2.5.2 is out and the repository moved to

whi-tw commented on 2020-02-18 10:14 (UTC) (edited on 2020-02-18 10:15 (UTC) by whi-tw)

Looks like the package needs to be modified like this:

diff --git a/PKGBUILD b/PKGBUILD
index bd2ac26..09dc1b4 100644
@@ -16,6 +16,8 @@ sha256sums=('334957137b31380d5df352c722fe142767ed46520a4279a80fe7f3917b9797df')
 package() {
   local _gemdir="$(ruby -e'puts Gem.default_dir')"

+  mkdir -p "$pkgdir/usr/bin"
   gem install \
     --ignore-dependencies \
     --no-user-install \

$pkgdir/usr/bin doesn't exist, so it needs to be created before gem install can install into it.

Felixoid commented on 2020-02-17 16:57 (UTC) (edited on 2020-02-18 09:07 (UTC) by Felixoid)

Hey @supermario. I'd like to help with maintaining this package. Wouldn't you mind to add me to co-maintainers?

Thank you for the update!

hcartiaux commented on 2019-05-03 15:30 (UTC)

It's not outdated, it just need to be rebuilt

aromaparanoia commented on 2019-01-14 20:19 (UTC) (edited on 2019-01-14 20:20 (UTC) by aromaparanoia)

Does this need to be rebuilt for Ruby 2.6.x?

$ puppet-lint
Traceback (most recent call last):
        2: from /bin/puppet-lint:23:in `<main>'
        1: from /usr/lib/ruby/2.6.0/rubygems.rb:302:in `activate_bin_path'
/usr/lib/ruby/2.6.0/rubygems.rb:283:in `find_spec_for_exe': can't find gem puppet-lint (>= 0.a) with executable puppet-lint (Gem::GemNotFoundException)

booshlinux commented on 2018-02-02 20:35 (UTC)

Should ruby-rdoc be added to the dependencies list? Package doesn't build without.

dwatzke commented on 2018-01-26 12:38 (UTC)

hi, it won't install without ruby-rdoc, dependency is missing from PKGBUILD

==> Starting package()... Successfully installed puppet-lint-2.3.3 ERROR: While executing gem ... (Gem::DocumentError) RDoc is not installed: cannot load such file -- rdoc/rdoc

after installing the ruby-rdoc package, it installs fine

joehillen commented on 2018-01-26 12:08 (UTC) (edited on 2018-01-26 12:08 (UTC) by joehillen)

==> Starting package()...
Traceback (most recent call last):
    1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- ubygems (LoadError)
ERROR:  While executing gem ... (Errno::ENOENT)
    No such file or directory @ dir_s_mkdir - /home/joe/.cache/pacaur/puppet-lint/pkg/puppet-lint/usr/bin
==> ERROR: A failure occurred in package().

supermario commented on 2017-03-09 00:23 (UTC) can you try building with plain makepkg? It's working for me commented on 2017-03-08 09:07 (UTC)

The package fails to install: ``` ==> Starting package()... ERROR: While executing gem ... (Errno::ENOENT) No such file or directory @ dir_s_mkdir - /home/anli/.cache/pacaur/puppet-lint/pkg/puppet-lint/usr/bin ==> ERROR: A failure occurred in package(). Aborting... :: failed to build puppet-lint package(s) ``` Cleaning pacaur's cache did not help.

andrekeller commented on 2015-02-24 13:08 (UTC)

Version 1.1.0 is out, updating version and sha256 (739f566cd4f1e77b92c1191217fdb59ce12353f3ec2703f30933d2bba877b35b) seems to be enough.

solarnz commented on 2014-09-17 11:15 (UTC)

Version 1.0.1 is out.