Package Details: pure 0.64-6

Git Clone URL: https://aur.archlinux.org/pure.git (read-only)
Package Base: pure
Description: Pure is a modern-style functional programming language based on term rewriting.
Upstream URL: http://purelang.bitbucket.org/
Licenses: GPL3, LGPL3
Groups: pure-complete, pure-base
Submitter: None
Maintainer: pure-aur
Last Packager: pure-aur
Votes: 15
Popularity: 0.000000
First Submitted: 2009-01-05 16:05
Last Updated: 2016-12-04 04:35

Latest Comments

aggraef commented on 2016-12-08 07:49

rcrath, that's right, Pure still depends on LLVM 3.5 right now. But note that the llvm35 package is only required at build time, so you can simply reinstall the llvm package after building Pure if you need it.

rcrath commented on 2016-12-08 04:01

gave error

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: llvm35 and llvm are in conflict

fortunately, nothing else requires llvm at present, so uninstalling llvm solved it.

asppsa commented on 2015-05-05 15:59

Hi there,

Pure should compile again now. I've made it depend on the new llvm35 package.

aggraef commented on 2015-04-27 17:51

Yeah, porting Pure over to MCJIT will be quite some work, I'm afraid, and unfortunately I'm busy with other things right now.

appsa, maybe we could grab the LLVM 3.5 PKGBUILD somewhere and provide that version on the AUR as a stopgap measure?

asppsa commented on 2015-04-26 23:10

Unfortunately Pure will not compile on LLVM 3.6 at present. I believe this is because Pure does not yet use MCJIT. See http://llvm.org/releases/3.6.0/docs/ReleaseNotes.html#the-old-jit-has-been-removed

FreeFull commented on 2015-04-24 03:29

Arch now comes with LLVM 3.6.0

asppsa commented on 2015-02-20 00:16

Ok I've made it depend on 'llvm<=3.5.99' -- hopefully this is robust enough!

Sorry for the delay in getting this sorted for you.

anks commented on 2015-02-19 14:21

Bumping last comment.

marcowahlsoft commented on 2015-01-30 21:17

Same thing as reported by luisrayas3 (see 2014-08-18 20:18).

This time with the package requires llvm 3.5.0 and current llvm in arch is 3.5.1. And further pure builds nicely with llvm 3.5.1 AFAICS.

luisrayas3 commented on 2014-08-18 20:18

pure seems to be working fine with the latest version of llvm (3.4.2) but the PKGBUILD requires <=3.4 which causes complaints during installation when your Arch system is up to date. If I just haven't hit the bug that actually does require a downgrade then change to use llvm34?

All comments