Package Details: py++ 1.0.0-3

Git Clone URL: https://aur.archlinux.org/py++.git (read-only)
Package Base: py++
Description: Py++ package and Boost.Python library provide a complete solution for interfacing Python and C++
Upstream URL: http://www.language-binding.net/index.html
Licenses: custom
Submitter: None
Maintainer: bchretien
Last Packager: bchretien
Votes: 15
Popularity: 0.034501
First Submitted: 2008-11-18 01:03
Last Updated: 2015-06-21 08:14

Required by (1)

  • ompl (requires py++) (optional)

Sources (1)

Latest Comments

blablubb1234 commented on 2014-10-17 07:52

Hi mate,

thanks for pointing this out to me :)
After rebuilding python2-pythonmagick I can import module PythonMagick without having to set the symlink libboost_python.so.1.55.0 to libboost_python.so.1.56.0.
In fact, I can even import it without having py++ installed as boost and boost-libs are enough.

Thank you very much for your help once again.

bchretien commented on 2014-10-16 23:10

@blablubb1234: you can probably check with this command (adapt it to your needs):

$ find /usr/lib -name "*.so" | xargs -i sh -c 'ldd {} | grep -E "libboost[a-z_.]*1.55" &>/dev/null && echo "Error: $(pacman -Qo {})"'

bchretien commented on 2014-10-16 22:54

@blablubb1234: after a Boost update, all packages linking with Boost need to be recompiled with the new version. FYI, blindly linking Boost 1.56 libraries with programs compiled with Boost 1.55 (as you did) may yield some unexpected results... Have you recompiled python2-pythonmagick after the Boost 1.56 update? Else it may be another python2-pythonmagick dependency that needs to be recompiled.

blablubb1234 commented on 2014-10-16 22:10

I needed py++ for using ImageMagick in Python (i.e. python2-pythonmagick).

However, after installing it I tried importing it in a test file imagemagick.py with the sole line "import PythonMagick" and got this error:

python2 imagemagick.py
Traceback (most recent call last):
File "/home/user/builds/Python/imagemagick.py", line 1, in <module>
import PythonMagick
File "/usr/lib/python2.7/site-packages/PythonMagick/__init__.py", line 1, in <module>
from . import _PythonMagick
ImportError: libboost_python.so.1.55.0: cannot open shared object file: No such file or directory

Now I had to do the following:

$ cd /usr/lib/
# ln -s libboost_python.so.1.56.0 libboost_python.so.1.55.0

Afterwards python2 imagemagick.py works just fine. Is py++ outdated or why doesn't it find the obviously newer file libboost_python.sp.1.56.0?

sftrytry commented on 2011-03-20 15:27

The same as pygccxml. As arch moves to python3, It would be better to add depends of python2 and use python2 setup.py in PKGBUILD.