Package Details: pyalpm-git 0.8.4.r100.gbca42ad-1

Git Clone URL: https://aur.archlinux.org/pyalpm-git.git (read-only)
Package Base: pyalpm-git
Description: Libalpm bindings for Python 3 (Git version)
Upstream URL: https://git.archlinux.org/pyalpm.git/
Licenses: GPL3
Conflicts: pyalpm
Provides: pyalpm=0.8.4.r100.gbca42ad
Submitter: None
Maintainer: yan12125 (yan12125_2)
Last Packager: yan12125_2
Votes: 7
Popularity: 0.000052
First Submitted: 2008-09-25 15:07
Last Updated: 2019-08-28 12:48

Dependencies (5)

Required by (34)

Sources (1)

Latest Comments

1 2 Next › Last »

yan12125 commented on 2019-08-28 13:02

@bartus: Thank you for the patch. I've applied the fix about python-setuptools. Howver, I'm concerned about using pacman -Q in PKGBUILD. Instead, I created another package https://aur.archlinux.org/packages/pyalpm-next-git/ that tracks the 'next' branch of pyalpm and is compatible with pacman-git.

bartus commented on 2019-08-27 12:42

@yan12125: I've been using pacman-git for a few months now, and really starts missing features relaying on pyalpm (namcap,aurman). Are you stand by what you've told @eli-schwartz, or would you consider incorporating some slick patch to allow users build pyalpm-git with both pacman and pacman-git.

Here's my suggestion: [***]

Have no idea, how far we are form next pacman release, but last commit on git.archlinux.org/pacman.git says Prepare translations for next release, so perhaps sooner than later ;)

yan12125 commented on 2019-01-19 06:56

I'd like to keep the compatibility with the stable pacman. I remember the last time I installed pacman-git, many software broke as they worked with the stable pacman only. If there's a patch working for both pacman-git and pacman, I'm glad to add it into this package even if it's not merged upstream.

eschwartz commented on 2019-01-18 14:58

In order to work with pacman-git>=5.1.1.r103.ge9d91a68 the following backwards-incompatible patch is needed: https://lists.archlinux.org/pipermail/arch-projects/2019-January/005139.html

Don't know whether it makes sense to depend on pacman-git for this purpose though.

yan12125 commented on 2016-01-31 13:39

Thanks updated. Now pyalpm-git requires pacman>=5 or above, which is in [testing] only. Just skip updating pyalpm-git before pacman 5 hits [core]

sl1pkn07 commented on 2016-01-31 12:53

please add this patch

https://lists.archlinux.org/pipermail/arch-projects/2016-January/004320.html

greetings

yan12125 commented on 2015-03-03 04:33

Thanks. Adopt and update.

falconindy commented on 2015-03-02 13:35

Disowned. Feel free to update.

yan12125 commented on 2015-03-02 09:49

Also, please use `git describe --long --tags` instead of `git describe` in pkgver() as what [1] suggests.

[1] https://wiki.archlinux.org/index.php/VCS_package_guidelines

yan12125 commented on 2015-03-02 09:44

Please use provides=("pyalpm=$pkgver") so that it can be used with namcap, which requires pyalpm>=0.5